Artifact builds give a crashy firefox

RESOLVED DUPLICATE of bug 1240134

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 1240134
2 years ago
5 months ago

People

(Reporter: mossop, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8722592 [details]
crash.txt

I was building from changeset aea9ba90eaa8 on fx-team and got a build that crashed on startup with the attached crash info. Doing a full build worked.
I just tried an artifact build at this revision on OS X and Linux and it started up fine. Fresher artifacts are probably available now, so I would say try again. I haven't seen anything go by recently in the build system that would have regressed this.

Comment 2

2 years ago
There are currently some binary components from local builds that mix with the pre-built binaries. This can cause a franken-build of sorts and could lead to crashes.

I'm going to assume this bug was related to XPIDLs, which are binary-related components still being built locally. So marking as dupe.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1240134

Updated

5 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.