Opening a room from the panel with a single tab open, closes the window in e10s mode

RESOLVED FIXED in Firefox 46

Status

defect
P2
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: standard8, Assigned: mikedeboer)

Tracking

unspecified
mozilla47
Points:
2
Dependency tree / graph

Firefox Tracking Flags

(e10sm9+, firefox46+ fixed, firefox47+ fixed)

Details

(Whiteboard: [e10s][triage][m-a: needs bug 1245813 landing first])

Attachments

(2 attachments)

Reporter

Description

3 years ago
STR:

1) Turn on e10s mode in FF
2) Set the loop.remote.autostart pref to true
3) Restart FF
4) Ensure you only have one tab open
5) Open the Loop panel
6) Click a button, e.g. "new room" or "get started"

Actual Results

The window closes

Expected Results

Window stays open and performs the correct action.
Assignee

Comment 1

3 years ago
Mark, this is what we've been through discussing this afternoon in code.
Attachment #8723210 - Flags: review?(standard8)
Assignee

Updated

3 years ago
Iteration: --- → 47.3 - Mar 7
Points: --- → 1
Assignee

Updated

3 years ago
Points: 1 → 2
Assignee

Updated

3 years ago
Status: NEW → ASSIGNED
Reporter

Comment 2

3 years ago
Comment on attachment 8723210 [details] [diff] [review]
Patch v1: prefix DOMWindowClose and DOMTitleChanged messages with the Social: prefix

Review of attachment 8723210 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. r=Standard8 I am tempted to say we should support both old & new APIs for a bit, but I think we should uplift the core patch to aurora as well to be safe there.
Attachment #8723210 - Flags: review?(standard8) → review+
Assignee

Comment 3

3 years ago
(In reply to Mark Banner (:standard8) from comment #2)
> Looks good. r=Standard8 I am tempted to say we should support both old & new
> APIs for a bit, but I think we should uplift the core patch to aurora as
> well to be safe there.

I think we should uplift it aurora indeed. I'll create a PR with the loop changes, so you can merge it at your leasure ;-)
Assignee

Comment 4

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/c75bc39acae8f6dc6f66cf3e479fc2ddd301c08a
Bug 1250847: prefix DOMWindowClose and DOMTitleChanged messages with the Social: prefix to assure they won't arrive at the global messageManager instance that TabBrowser is listening to. It mixes things up in twisted, unexpected ways if we don't. r=Standard8
Assignee

Comment 6

3 years ago
Comment on attachment 8723815 [details] [review]
[loop] mikedeboer:bug-1250847-prefixMessages > mozilla:master

Carrying over r=Standard8.
Attachment #8723815 - Flags: review+
Whiteboard: [e10s] → [e10s][triage]

Comment 7

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/c75bc39acae8
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
Assignee

Comment 9

3 years ago
Comment on attachment 8723210 [details] [diff] [review]
Patch v1: prefix DOMWindowClose and DOMTitleChanged messages with the Social: prefix

Approval Request Comment
[Feature/regressing bug #]: e10s
[User impact if declined]: once we enable e10s support for Hello, opening a conversation for the first time in a window with one tab open, the window will be closed.
[Describe test coverage new/current, TreeHerder]: landed on m-c, tests pass.
[Risks and why]: minor - Hello system add-on need to be updated to work.
[String/UUID change made/needed]: n/a.
Attachment #8723210 - Flags: approval-mozilla-aurora?
Reporter

Updated

3 years ago
Duplicate of this bug: 1252513
Regression if we have e10s enabled, tracking and marking affected.
Comment on attachment 8723210 [details] [diff] [review]
Patch v1: prefix DOMWindowClose and DOMTitleChanged messages with the Social: prefix

Fix for an e10s regression that affects Hello, please uplift to aurora.
Attachment #8723210 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Reporter

Updated

3 years ago
Depends on: 1245813
Whiteboard: [e10s][triage] → [e10s][triage][m-a: needs bug 1245813 landing first]
You need to log in before you can comment on or make changes to this bug.