Closed Bug 1250938 Opened 4 years ago Closed 2 years ago

crash in nsWebBrowserPersist::CleanupLocalFiles

Categories

(SeaMonkey :: Download & File Handling, defect, critical)

x86
All
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1224326

People

(Reporter: wsmwk, Unassigned)

References

Details

(Keywords: crash)

Crash Data

#2 crash for Seamonkey 2.39 https://crash-stats.mozilla.com/topcrashers/?product=SeaMonkey&version=2.39&days=14  No other produce has this crash

bp-1343ac9f-37d2-458f-8064-4702b2151209. comments typically mention downloads, like "done this twice by stopping a download. it tells me that the download failed obviously and then this crash happens when I click ok. "

 0 	xul.dll	nsWebBrowserPersist::CleanupLocalFiles()	embedding/components/webbrowserpersist/nsWebBrowserPersist.cpp
1 	xul.dll	nsWebBrowserPersist::EndDownload(nsresult)	embedding/components/webbrowserpersist/nsWebBrowserPersist.cpp
2 	xul.dll	nsWebBrowserPersist::Cancel(nsresult)	embedding/components/webbrowserpersist/nsWebBrowserPersist.cpp
3 	xul.dll	nsDownload::CancelTransfer()	toolkit/components/downloads/nsDownloadManager.cpp
4 	xul.dll	nsDownload::Cancel()	toolkit/components/downloads/nsDownloadManager.cpp
5 	xul.dll	NS_InvokeByIndex	xpcom/reflect/xptcall/md/win32/xptcinvoke.cpp
This one probably is the root for "Bug 1224326 - CRASH when cancel download"

@Wayne Mery
Thank your for the hint!
See Also: → 1224326
[Tracking Requested - why for this release]:
Hi,
I had it on Linux amd64.
https://crash-stats.mozilla.com/report/index/3236a973-9afb-4826-b579-15d5c2160528
So the platform should be changed.
https://crash-stats.mozilla.com/topcrashers/?product=SeaMonkey&version=2.39&days=14 claims first appearance was 2015-11-04 

The first wo crashes I find are
422d99bc-de04-417c-8b6a-782ac2151116	2015-11-16 15:40:21 	2.39b0 	20151028234211 	Windows NT
c6ccec55-9c90-429e-9bd2-1f7af2151115	2015-11-15 17:16:34 	2.39 	20151103174417 	Linux
OS: Windows NT → All
SeaMonkey 2.40 Windows 10
User agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0 SeaMonkey/2.40
Build identifier: 20160120202951

Crashed when I was attempting to download updated Java JRE. Stopped and tried to restart the download - crash

https://crash-stats.mozilla.com/report/index/1ad83f4f-b135-4f16-a222-e06d72160721
This is fixed in 2.52+ with switching to jsdownloads in bug 888915. A backport would be possible but at this point in time we need all dev resources for 2.57. So wontfix for 2.49.x. Sorry, ran into this myself a few times and I know that this s*cks.

If someone wants to do a backport let me know and I point out what needs to be done.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1224326
You need to log in before you can comment on or make changes to this bug.