Media playback problems on Pixel C

RESOLVED INVALID

Status

()

P2
normal
RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: snorp, Assigned: esawin)

Tracking

({crash})

45 Branch
crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

I've seen a couple crashes that were misreported [0][1] and show a crash while trying to play media. The logcat has the following just before the crash in both cases:

02-23 22:41:33.251  5551 11595 W art     : Native thread exiting without having called DetachCurrentThread (maybe it's going to use a pthread_key_create destructor?): Thread[52,tid=11595,Native,Thread*=0xf8381870,peer=0x134d20a0,"Thread-1953"]
02-23 22:41:33.327  5551 11651 I OMXClient: Using client-side OMX mux.
02-23 22:41:33.334  5551 11650 I MediaCodec: [OMX.Nvidia.h264.decode] setting surface generation to 5684230
02-23 22:41:33.348  5551 11651 D SurfaceUtils: set up nativeWindow 0xf80b9828 for 1280x720, color 0x106, rotation 0, usage 0x2b00
02-23 22:41:33.385  5551 11651 D SurfaceUtils: set up nativeWindow 0xf80b9828 for 1280x720, color 0x146, rotation 0, usage 0x2b00
02-23 22:41:33.386  5551 11651 W ACodec  : [OMX.Nvidia.h264.decode] setting nBufferCountActual to 15 failed: -1010
02-23 22:41:33.386  5551 11651 W ACodec  : [OMX.Nvidia.h264.decode] setting nBufferCountActual to 14 failed: -1010
02-23 22:41:33.386  5551 11651 W ACodec  : [OMX.Nvidia.h264.decode] setting nBufferCountActual to 13 failed: -1010
02-23 22:41:33.619  5551  5612 W google-breakpad: ExceptionHandler::GenerateDump cloned child 

[0] https://crash-stats.mozilla.com/report/index/dc2985a7-a86a-4771-8370-e10512160224
[1] https://crash-stats.mozilla.com/report/index/df53e1dc-42c1-4741-89dd-3acf62160224
Eugen, can you order one of these things and see if you can find anything.
Flags: needinfo?(esawin)
(Assignee)

Comment 2

3 years ago
The codec errors from comment 0 seem to be unrelated to the crash, I see them during regular H.264 playback, too.

So far, I've only managed to crash Fennec on the device by spamming VP9 video tabs, it's semi-reproducible and crashes on:

03-07 22:48:52.553 21831 21907 E Gecko   : ShmemAndroid::ShareToProcess(): Too many open files (24)
03-07 22:48:52.553 21831 21907 E Gecko   : ShmemAndroid::Create():open: Too many open files (24)
03-07 22:48:52.553 21831 21907 F MOZ_CRASH: Hit MOZ_CRASH() at /home/esawin/dev/g/ipc/glue/CrossProcessMutex_posix.cpp:59
--------- beginning of crash
03-07 22:48:52.553 21831 21907 F libc    : Fatal signal 11 (SIGSEGV), code 1, fault addr 0x0 in tid 21907 (Thread-160)

I'm looking for a better STR which rules OOM issues out.
Flags: needinfo?(esawin)
(Assignee)

Comment 3

3 years ago
Chrome suffers from the same issue, producing almost the same error log output.

The platform is leaking file descriptors, e.g., required for dup'ing for shared memory use cases.
Blocks: 1257115
Keywords: crash
Priority: -- → P2
Blocks: 1257777
(Assignee)

Comment 4

2 years ago
Closing since it's a platform bug (Android/device).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.