Clear icon in devtools is ambigous

VERIFIED FIXED in Firefox 47

Status

defect
P3
normal
VERIFIED FIXED
3 years ago
11 months ago

People

(Reporter: ntim, Assigned: ntim)

Tracking

unspecified
Firefox 48

Firefox Tracking Flags

(firefox46 unaffected, firefox47+ verified, firefox48 verified)

Details

(Whiteboard: [devtools-ux][btpp-backlog])

Attachments

(2 attachments, 3 obsolete attachments)

(Assignee)

Description

3 years ago
It means "This is prohibited" rather than "Clear this". A trash can would work better in my opinion.
(Assignee)

Updated

3 years ago
Whiteboard: [devtools-ux]
Assignee: nobody → hholmes
Priority: -- → P3
Whiteboard: [devtools-ux] → [devtools-ux][btpp-backlog]
(Assignee)

Comment 3

3 years ago
These are some SVGs I put up for testing (mainly because of pixel-snapping concerns).
(Assignee)

Updated

3 years ago
Attachment #8733574 - Attachment description: clear-rounded-corners.svg → clear-rounded-corners.svg - coordinates not pixel snapped
(Assignee)

Comment 4

3 years ago
(Assignee)

Comment 5

3 years ago
attachment 8733574 [details] and attachment 8733580 [details] basically produce the same result. The resulting icon is not blurry, but the lateral lines are a bit thinner.
(Assignee)

Comment 6

3 years ago
Posted image no-bottom-round-corners.svg (obsolete) —
See Also: → 1220208
(Assignee)

Comment 7

3 years ago
Posted image clear-final.svg
I decided to go with this icon, for more consistency. The thin icon can be applied once all other icons will be changed to thinner icons.
Attachment #8733574 - Attachment is obsolete: true
Attachment #8733580 - Attachment is obsolete: true
Attachment #8733609 - Attachment is obsolete: true
Attachment #8734918 - Flags: ui-review?(hholmes)
Attachment #8734918 - Flags: ui-review?(hholmes) → ui-review+
(Assignee)

Comment 8

3 years ago
Posted patch PatchSplinter Review
Helen, Thanks for the review!
Assignee: hholmes → ntim.bugs
Status: NEW → ASSIGNED
Attachment #8735433 - Flags: review?(bgrinstead)
(Assignee)

Comment 9

3 years ago
[Tracking Requested - why for this release]: The clear icon was introduced in Firefox 47, and having 2 different clear icons across 2 subsequent releases feels confusing. Let's have 1 common icon across Firefox 47 and 48
Comment on attachment 8735433 [details] [diff] [review]
Patch

Review of attachment 8735433 [details] [diff] [review]:
-----------------------------------------------------------------

Works for me
Attachment #8735433 - Flags: review?(bgrinstead) → review+

Comment 12

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e5c8ba7cabaa
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
(Assignee)

Comment 13

3 years ago
Comment on attachment 8735433 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: New clear icon introduced in 47
[User impact if declined]: Different icons across 2 different versions which might confuse users when they upgrade to 48
[Describe test coverage new/current, TreeHerder]: on Nightly
[Risks and why]: Low, image only change
[String/UUID change made/needed]: none
Attachment #8735433 - Flags: approval-mozilla-aurora?
Comment on attachment 8735433 [details] [diff] [review]
Patch

SVG change, the new icon is more appropriate and consistent, Aurora47+
Attachment #8735433 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Successfully reproduce this bug on Nightly 47.0a1 (2016-02-25) (Build ID: 20160225030209) on Linux, 64 Bit.

This Bug is now verified as fixed on Latest Firefox Nightly (2016-04-14) ; (Build ID: 20160414030247)
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0 and

Latest Firefox Developer Edition 47.0a2 (2016-04-14) ; (Build ID: 20160414004009)
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
OS: Linux 3.19.0-58-generic x86-64
QA Whiteboard: [testday-20160415]
(Assignee)

Updated

3 years ago
Status: RESOLVED → VERIFIED

Updated

11 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.