Animated gifs set as background blink

VERIFIED FIXED in Firefox 48

Status

()

defect
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: arni2033, Assigned: seth)

Tracking

({regression, regressionwindow-wanted})

Trunk
mozilla48
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox44 unaffected, firefox45 wontfix, firefox46 wontfix, firefox47 wontfix, firefox48 verified)

Details

(Whiteboard: [gfx-noted], )

Attachments

(2 attachments)

Reporter

Description

3 years ago
>>>   My Info:   Win7_64, Nightly 47, 32bit, ID 20160224030246
STR:
1. Open http://www.albinoblacksheep.com/games/missilegame3d
2. Scroll the page to the end
3. Hover mouse over the white area in #footer
4. Wait until "Mario" and "Luigi" gifs will appear at the bottom of that white area

AR:  Those 2 gifs do blink.
ER:  They shouldn't blink.

Please improve the Summary

This is regression between 2015-10-30 and 2015-10-31, Firefox 45. (regressionwindow-wanted)
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=540fe6d9b147b3e37713aeeae944fad7661a5685&tochange=58593839ebcedb976068fca5901af41cf48912d9
Flags: needinfo?(mstange)
Confirmed. I see this on OS X, too.

Comment 3

3 years ago
Via local build,
Last Good: d9da665e6f0d
First Bad: 7e3476b5b99d

Triggered by: 7e3476b5b99d	Markus Stange — Bug 947062 - Layerize background images with animated background-position if possible. r=mattwoodrow
Blocks: 947062
There seems to be an existing issue when this animated gif is used as an ImageLayer. Bug 947062 made us use an ImageLayer on this page, so it exposed the bug. But the underlying issue seems to have existed before.
No longer blocks: 947062
Flags: needinfo?(mstange)
Alice, can you find a new regression range with this testcase?

Comment 6

3 years ago
(In reply to Markus Stange [:mstange] from comment #5)
> Created attachment 8724027 [details]
> different testcase without background-position (but still with ImageLayer)
> 
> Alice, can you find a new regression range with this testcase?

Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e0f5ea8e9082&tochange=bd4287c14070

Regressed by: bd4287c14070	Matt Woodrow — Bug 1039020 - Layerize background-attachment:fixed for all elements, not just the root one. r=roc
Blocks: 1039020
Thanks! This is a surprising result - again we just found the cause of the ImageLayer, but not why the ImageLayer is buggy. So this goes even further back.

Seth, can you look into this? If it makes your job easier, I can try to create another testcase that uses still another method of forcing an ImageLayer, and then we can try to find a new regression range. Would you prefer that or do you just want to debug the bug?
Flags: needinfo?(seth)
Whiteboard: [gfx-noted]
Assignee

Comment 8

3 years ago
(In reply to Markus Stange [:mstange] from comment #7)
> Thanks! This is a surprising result - again we just found the cause of the
> ImageLayer, but not why the ImageLayer is buggy. So this goes even further
> back.
> 
> Seth, can you look into this? If it makes your job easier, I can try to
> create another testcase that uses still another method of forcing an
> ImageLayer, and then we can try to find a new regression range. Would you
> prefer that or do you just want to debug the bug?

Let me take a look. We've encountered some situations where we didn't invalidate the ImageContainer associated with the ImageLayer correctly during animation, but I don't think that should cause this bug. It looks a lot like there's some point in the animation where the ImageContainer just ends up containing garbage...
Assignee: nobody → seth
Looks like this got fixed by bug 1247152.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Depends on: 1247152
Flags: needinfo?(seth)
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
Regression from 45, fixed in 48. It seems too late in the 47 beta cycle to me to uplift the patches from bug 1247152, so, wontfix there as well.
QA Whiteboard: [good first verify]
I have reproduced this bug with Release 47.0 on Linux Mint, 64 Bit !

The Bug's fix is verified on Latest beta  48.0b1.

Build ID 	20160606200529
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Thanks  Md.Tarikul Islam Oashi for helping us.
I also verified this issue on Firefox 48.0b6 and on Windows 10 x64, Mac OS X 10.10.5 and on Ubuntu 16.04 x64.
I am marking this issue Verified Fixed, since is no longer reproducible.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.