Wrong position reported to GTKIMContext if zoom in level > 100% (GTK2 build only)

RESOLVED WONTFIX

Status

()

Core
Widget: Gtk
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: yan12125, Unassigned)

Tracking

({inputmethod})

44 Branch
Unspecified
Linux
inputmethod
Points:
---

Firefox Tracking Flags

(firefox44 affected, firefox45 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8724553 [details]
A screenshot of wrong placement of the candidate panel

Steps to reproduce:

1. Start Firefox with a new profile
`mkdir /tmp/firefox-test && firefox --profile /tmp/firefox-test`
2. Ctrl-Shift-+ to zoom in
2. Switch to a Chinese IME. Here I use ibus-chewing
3. Type some Chinese characters. Choose from candidates by pressing arrow down key.

Expected results:
The candidate panel is placed correctly.

Actual results:
The candidate panel is put at a difference place. See the attachment.

More information:
* Arch Linux x86_64 with Firefox 44.0.2-2. Arch-specific patches can be found at https://projects.archlinux.org/svntogit/packages.git/tree/firefox/trunk
* Only Firefox is affected. Other programs including Google Chrome and xfce4-terminal works fine.

My ideas:
I guess the call to gtk_im_context_set_cursor_location in widget/gtk/IMContextWrapper.cpp is incorrect.
(Reporter)

Updated

2 years ago
Component: Untriaged → Widget: Gtk
Product: Firefox → Core

Updated

2 years ago
Keywords: inputmethod

Comment 1

2 years ago
This seems to be fixed on Aurora46.0a2.

Reporter, could you test with Aurora46.0a2(Developer Edition[1])?

[1]https://www.mozilla.org/ja/firefox/channel/#developer
Flags: needinfo?(yan12125)
(Reporter)

Comment 3

2 years ago
Yep it's fixed in 46.0a2, while not in 45.0b10. Thanks for the information!
Flags: needinfo?(yan12125)

Updated

2 years ago
status-firefox44: --- → affected
status-firefox45: --- → affected
status-firefox46: --- → fixed
This depends on whether GTK2 or GTK3.  Because this was fixed by Firefox/GTK3 (bug 1181000) and Firefox 45 still use GTK2.

Updated

2 years ago
status-firefox46: fixed → ---

Updated

2 years ago
Summary: Wrong position reported to GTKIMContext if zoom in level > 100% → Wrong position reported to GTKIMContext if zoom in level > 100% (GTK2 build only)
(Reporter)

Comment 5

2 years ago
Arch Linux upgrades Firefox to 46.0, but the bug is still. Even worse, the tarball [1] exihibits the same bug now. I'm not sure whether it's caused by a recent upgrade of GTK3 or not. Currently GTK 3.20 is used. [2]

[1] https://www.mozilla.org/en-US/firefox/channel/#firefox
[2] https://git.archlinux.org/svntogit/packages.git/tree/gtk3/trunk/PKGBUILD
(Reporter)

Comment 6

2 years ago
Just created a test user account and tried again. No more mysterious ~/.gtk* files. Same results.

Comment 7

2 years ago
Now, 46.0 is "disabled de10s" by default.
So, We hit Bug 1261671. And Bug 1261671 is "WONTFIX" for 46.0 as well as 45(incl ESR45) :(
(Reporter)

Comment 8

2 years ago
Thanks for the information. Backported and fixed.
(Reporter)

Comment 9

2 years ago
I guess this ticket can be closed as the stable version is now built with GTK+3?
(Reporter)

Comment 10

2 years ago
I'd like to mark this bug as WONTFIX, as Firefox now defaults to GTK+3. Is it OK?
Flags: needinfo?(m_kato)
(In reply to Yen Chi Hsuan from comment #10)
> I'd like to mark this bug as WONTFIX, as Firefox now defaults to GTK+3. Is
> it OK?

Yes.  As long as I test on Nightly/GTK3, this doesn't occur.
Flags: needinfo?(m_kato)
(Reporter)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.