Closed Bug 1251998 Opened 4 years ago Closed 3 years ago

keyword doesn't work for synced bookmark

Categories

(Firefox :: Bookmarks & History, defect)

44 Branch
x86
Windows 10
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1150678

People

(Reporter: mozilla, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160210153822

Steps to reproduce:

Firefox browser 44.0.2 on old computer had a bookmark with a keyword (e.g., finance.yahoo.com with keyword q).
In that browser I created a firefox account to enable Sync.
On new computer, installed Firefox browser 44.0.2, signed into account to Sync.
The new browser gets the old bookmarks as expected, and if I view the bookmark for finance.yahoo.com, it shows the keyword q.
I typed q in the address bar in the new browser.


Actual results:

It did a google search for "q", i.e., it didn't recognize the keyword.


Expected results:

It should've gone to finance.yahoo.com.

If I view properties of the bookmark in the new browser and click Save, the problem still happens.
If I change the keyword to something else (e.g., q2) in the new browser, it works.  I can then change the keyword back to the original "q", and it works.
I tried reproducing after the initial sync, by adding a new bookmark with keyword in the old browser, and letting the new browser get it via sync; but in that case the keyword worked in the new browser.  Possibly the problem only comes up for bookmarks that existed before the initial sync.
My old browser is on Windows XP, new browser is on Windows 10 (I don't know if the OS matters for this issue).
OS: Unspecified → Windows 10
Hardware: Unspecified → x86
Component: Untriaged → Bookmarks & History
A related problem: When I edit a bookmark that had a keyword, change the Location, click Done; the keyword disappears from the bookmark.  I have to edit it again and add the keyword back.
Just happened to me when I accidentally enabled sync on my 47.0b6
FWIW, it self-repairs after a browser restart.
It appears as though this is a subset of bug 1150678.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1150678
You need to log in before you can comment on or make changes to this bug.