renaming a bookmark also renames all bookmarks with same URL

VERIFIED DUPLICATE of bug 51683

Status

SeaMonkey
Bookmarks & History
VERIFIED DUPLICATE of bug 51683
17 years ago
14 years ago

People

(Reporter: Jesse Ruderman, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Steps to reproduce:
1. Create two bookmarks in different folders pointing to the same URL.  (It
doesn't matter whether the bookmarks are in personal toolbar folders or other
bookmark folders.)
2. Rename one of them (right-click on personal toolbar item and click "rename",
or right-click in bookmark manager and click "rename").

Result: both bookmarks are renamed.  If you're in bookmark manager, then
depending on compositor's mood, the other instance of the bookmark might not
appear to rename until you click on it.

Alternate steps to reproduce:
1. Bookmark http://mozilla.org/ with the name "mozilla.org".
2. Go to http://mozilla.org/.
3. Boomkarks > File Bookmark, create a bookmark called "moz" in a new folder.

Result: a new bookmark called "moz" is created, and the old bookmark is renamed
to "moz".

This is annoying when you're trying to reduce the lengths of the names of your
personal toolbar buttons/links.

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 51683 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
VERIFIED Dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.