Closed Bug 1252345 Opened 4 years ago Closed 4 years ago

[e10s] browser_markup_copy_image_data.js and browser_markup_image_tooltip.js fail on OSX

Categories

(DevTools :: Inspector, defect, P1)

Unspecified
macOS
defect

Tracking

(e10s+, firefox47 affected, firefox48 fixed)

RESOLVED FIXED
Firefox 48
Tracking Status
e10s + ---
firefox47 --- affected
firefox48 --- fixed

People

(Reporter: RyanVM, Assigned: pbro)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [btpp-fix-now])

Attachments

(1 file)

Maybe related to bug 1238022? I could see de-CPOWification helping with an error like this.

https://treeherder.mozilla.org/logviewer.html#?job_id=17384347&repo=try

 17:44:01     INFO -  178 INFO TEST-START | devtools/client/inspector/markup/test/browser_markup_copy_image_data.js
 17:44:01     INFO -  179 INFO Entering test bound
 17:44:01     INFO -  180 INFO Adding a new tab with URL: data:text/html,markup view copy image as data-uri
 17:44:01     INFO -  181 INFO Waiting for event: 'load' on [object XULElement].
 17:44:02     INFO -  182 INFO Got event: 'load' on [object XULElement].
 17:44:02     INFO -  183 INFO Tab added and finished loading
 17:44:02     INFO -  TEST-INFO | started process screencapture
 17:44:02     INFO -  TEST-INFO | screencapture: exit 0
 17:44:02     INFO -  184 INFO checking window state
 17:44:02     INFO -  185 INFO TEST-UNEXPECTED-FAIL | devtools/client/inspector/markup/test/browser_markup_copy_image_data.js | Uncaught exception - at chrome://mochitests/content/browser/devtools/client/inspector/markup/test/browser_markup_copy_image_data.js:45 - Error: cross-process JS call failed
 17:44:02     INFO -  Stack trace:
 17:44:02     INFO -      createDocument@chrome://mochitests/content/browser/devtools/client/inspector/markup/test/browser_markup_copy_image_data.js:45:17
 17:44:02     INFO -      @chrome://mochitests/content/browser/devtools/client/inspector/markup/test/browser_markup_copy_image_data.js:18:3
 17:44:02     INFO -      Tester_execTest@chrome://mochikit/content/browser-test.js:786:9
 17:44:02     INFO -      Tester.prototype.nextTest</<@chrome://mochikit/content/browser-test.js:706:7
 17:44:02     INFO -      SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:741:59
 17:44:02     INFO -      Tester_execTest@chrome://mochikit/content/browser-test.js:786:9
 17:44:02     INFO -      Tester.prototype.nextTest</<@chrome://mochikit/content/browser-test.js:706:7
 17:44:02     INFO -      SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:741:59
 17:44:02     INFO -  186 INFO Leaving test bound
 17:44:02     INFO -  187 INFO Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "data:text/html,markup%20view%20copy%20image%20as%20data-uri" line: 0}]
 17:44:02     INFO -  MEMORY STAT | vsize 3899MB | residentFast 458MB | heapAllocated 172MB
17:44:02 INFO - 188 INFO TEST-OK | devtools/client/inspector/markup/test/browser_markup_copy_image_data.js | took 345ms
Flags: needinfo?(pbrosset)
Summary: [e10s] browser_markup_copy_image_data.js fails on OSX → [e10s] browser_markup_copy_image_data.js and browser_markup_image_tooltip.js fail on OSX
I have filed bug 1252099 to get rid of CPOW usage in all markup-view tests.
I'm starting to work on this today.
Depends on: 1252099
Flags: needinfo?(pbrosset)
Priority: -- → P1
Whiteboard: [btpp-fix-now]
Was bug 1252099 expected to fix this? I see these tests are still being skipped on OSX.
Flags: needinfo?(pbrosset)
Bug 1252099 removed all instances of CPOW usage in devtools/client/inspector/markup/test, so hopefully, it should have fixed the cause of these test failures.
But indeed, I did not remove the skip-if in that bug.

I'll upload a patch to do this here and try build with many mac&e10s re triggers to see how things are going now.
Flags: needinfo?(pbrosset)
Assignee: nobody → pbrosset
Status: NEW → ASSIGNED
Keywords: leave-open
https://hg.mozilla.org/mozilla-central/rev/c13b55898a6a
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.