Closed Bug 1252458 Opened 6 years ago Closed 6 years ago

On non-US Yahoo the "Sign In" button has double underline on hover

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set
normal

Tracking

(firefox47 verified, firefox48 verified)

VERIFIED FIXED
Tracking Status
firefox47 --- verified
firefox48 --- verified

People

(Reporter: Ovidiu, Unassigned)

References

()

Details

(Whiteboard: [sitewait] [css] )

Attachments

(2 files)

Tested on Mac OS X 10.6 and 10.10 and Win 7 x64 with Firefox Nightly and DeveloperEdition.

STR:

1. Go to yahoo.com
2. Go to Sign in 

Actual results: Sign in is double underlined 

Expected results: Sign in is underlined
It looks fine to me.  Can you make a screenshot of the error please?
Flags: needinfo?(ovidiu.boca)
Flags: needinfo?(ovidiu.boca)
Summary: On Yahoo the "Sing In" button has double lines → On Yahoo the "Sign In" button has double lines
I see this at https://ro.yahoo.com/ when I hover over "Sign in", but I don't see it on the US version.
There's an underline specified on both the a element and the b element inside it.  The b element has 'vertical-align: middle', which puts it at a different vertical position.  Thus the two underlines show up at different vertical positions.  This seems like correct behavior on Gecko's part.

I haven't looked into whether they send the same CSS to other browsers.
Component: Layout: Text → Layout: Block and Inline
I did the same poking in Chrome's inspector, and Chrome does also get both underlines and the vertical-align: middle.  The vertical-align: middle does also cause a position difference.  But the two underlines are both drawn, and draw on top of each other.
Component: Layout: Block and Inline → Desktop
Product: Core → Tech Evangelism
Summary: On Yahoo the "Sign In" button has double lines → On Romanian Yahoo the "Sign In" button has double underline on hover
Tested with this link: https://ca.yahoo.com/  the same behaviour.
Summary: On Romanian Yahoo the "Sign In" button has double underline on hover → On non-US Yahoo the "Sign In" button has double underline on hover
Karl, can you get in contact with Yahoo! about this? See Comment #4 for the diagnosis.
Flags: needinfo?(kdubost)
Whiteboard: [contactready]
Sent an email to my contact in Yahoo!
Flags: needinfo?(kdubost)
Whiteboard: [contactready] → [sitewait] [css]
fyi

>  Hi Karl! We have tracked down the right owner. Internal bug is YAHOODOTCO-19565. I'll try to keep you posted, thanks again!
I think it has been fixed.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Tested on Mac OS X 10.10, Windows 7 x64 and Ubuntu 15.04 with the Firefox Nightly 48.0a1 DeveloperEdition 47.0a2 and Firefox 45 release and I can't reproduce this bug anymore.
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.