Closed Bug 1252589 Opened 4 years ago Closed 4 years ago

Startup crash in instrumented PGO executables on Visual Studio 2015 Update 2 CTP

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: gps, Unassigned)

References

()

Details

PGO instrumented executables built with Visual Studio 2015 Update 2 CTP crash on startup. pgort140.dll is at the top of the stack. libmozglue malloc related calls are often in the stack.

I'm going to file a bug report with Microsoft because this smells like an upstream regression from 2015u1.
Visual Studio 2015 Update RC has been released. https://www.visualstudio.com/en-us/news/vs2015-update2-vs.aspx

I'm installing it now to see if the startup crash persists.
Visual Studio 2015 Update 2 RC (released today) no longer exhibits this issue!

Resolving.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.