Able to scroll past the end of the page on American Airlines [aa.com]

RESOLVED FIXED in Firefox 48

Status

()

Firefox for Android
Toolbar
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: kbrosnan, Assigned: rbarker)

Tracking

47 Branch
Firefox 48
All
Android
Points:
---

Firefox Tracking Flags

(firefox46 unaffected, firefox47 unaffected, firefox48 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
1) Visit http://www.aa.com
2) perform a slow fling (leave your finger on the device to best see the issue)
3) notice the white bar at the bottom of the screen
4) content snaps back to the bottom of the screen on finger release

Using a Nexus 5 running Android 6.0
This is a bug from the dynamic toolbar implementation, I think. Should happen on any page that is long enough to scroll off the toolbar and short enough to reach the bottom of the page in a single swipe. The resize doesn't happen until the finger is lifted and until that happens the scroll offset is allowed to go to the higher value (based on the smaller window size). We should be able to fix this either in Java or in some Fennec-specific compositor code like what we have already for fixed-pos items.
Blocks: 1206874
(Assignee)

Updated

2 years ago
Assignee: nobody → rbarker
(Assignee)

Comment 2

2 years ago
Created attachment 8730977 [details] [diff] [review]
0001-Bug-1252708-Able-to-scroll-past-the-end-of-the-page-in-Fennec-with-APZ-enabled-r-16031516-980f413.patch
Attachment #8730977 - Flags: review?(bugmail.mozilla)
Comment on attachment 8730977 [details] [diff] [review]
0001-Bug-1252708-Able-to-scroll-past-the-end-of-the-page-in-Fennec-with-APZ-enabled-r-16031516-980f413.patch

Review of attachment 8730977 [details] [diff] [review]:
-----------------------------------------------------------------

This is a little scary to me and it would be good to test panning madly up and down (with the finger held down) on some heavy pages with resize event listeners. Also run through the tests on http://people.mozilla.org/~kgupta/bug/1180295.html (ignore step 11, since the zoomed view is disabled) to make sure there's no expected behaviour. If all that is good then I don't have any objections.

::: mobile/android/base/java/org/mozilla/gecko/gfx/DynamicToolbarAnimator.java
@@ +440,5 @@
>              return false;
>          }
>  
> +        if (mToolbarTranslation == mMaxTranslation) {
> +            shiftLayerView(mMaxTranslation);

Add Log.v calls in both of these branches that logs some useful message that we're doing this.
Attachment #8730977 - Flags: review?(bugmail.mozilla) → review+
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #3)
> no expected behaviour

no *un*expected behaviour, is what I meant :)

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/c7969fc23e51
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox48: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
status-firefox47: affected → unaffected
Version: unspecified → 47 Branch
You need to log in before you can comment on or make changes to this bug.