css background-image doesn't reload

VERIFIED WORKSFORME

Status

()

Core
Layout: Images
--
minor
VERIFIED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Eduardo Costa, Unassigned)

Tracking

({css1})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CSS1-5.3.3])

Attachments

(1 attachment, 1 obsolete attachment)

1.45 KB, application/zip
Details
(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020415

The image pointed by a "background-image" of a linked CSS doesn't update after a
"Reload".

Reproducible: Always
Steps to Reproduce:
1. Create a HTML and a CSS with "background-image"s
2. Change the image
3. Try to reload the page

Actual Results:  The image doesn't changes

Expected Results:  The image must be updated

I have a local apache running perfect, and I use it to make my sites.
The page I'm building have CSS, and inside it, there are some "background-image"
properties. If I change the image it points to, Mozilla doesn't update when I
hit "Reload". I haven't tested it with local files.

in HTML: <link rel="stylesheet" type="text/css" href="aux.css">
in CSS: .lbgne { background: #9f9fcf url(table.ne.gif) no-repeat; }

Comment 1

16 years ago
What if you hold shift while clicking on reload? We're probably caching the
images and reloading doesn't skip the cache. shift-reload skips the cache.
Not a DOM problem...
Assignee: jst → dbaron
Component: DOM Style → Style System
(Reporter)

Comment 3

16 years ago
I shift-reloaded, but it still not working.
And sorry about the DOM...

Comment 4

16 years ago
can we get a testcase? And what element is this background image on? a <table> ?
(Reporter)

Comment 5

16 years ago
Well, I created a "Bug Sample Page":
http://www.tpk.com.br/bz125273/

There are six files: index.html, main.css, bg.gif, bg1.gif, change.php and
change.php3. "change.php3" exchanges "bg.gif" and "bg1.gif", "index.html" has a
link to it, and "change.php" is the source for "change.php3".

After loading the page, you can click on the link. "change.php3" will do its
work, and redirect you to "index.html". The background will not change
immediatelly (even with a 'shift-reload', but, I found that after some time
(half a minute or more), the bg changes with a simple 'reload'.

It's not a problem to a surfer, but for a webmaster, this delay is a headache.

Comment 6

16 years ago
additional platform OS X/0.9.9

I'm seeing this also. With that test page watch the following location for the
image change:

http://www.tpk.com.br/bz125273/bg1.gif
This seems like it probably has something to do with the way images are loaded
from painting routines.
Status: UNCONFIRMED → NEW
Ever confirmed: true
->ImageLib.  This is closely related to bug 121787.
Assignee: dbaron → pavlov
Component: Style System → ImageLib
Depends on: 121787
Keywords: css1
QA Contact: ian → tpreston

Updated

16 years ago
Component: ImageLib → Image: Layout
Target Milestone: --- → mozilla1.1alpha

Comment 9

15 years ago
Reconfirmed using FizzillaCFM/2002070913. Setting All/All.
OS: Linux → All
Hardware: PC → All
bug 121787 duped into bug 57607.
Whiteboard: [CSS1-5.3.3]

Comment 11

15 years ago
Confirm bug still exists in Moz 2003022108.

Additional note: If css is changed in a way that doesn't affect the background,
the changes do appear. Conclusion, the css file is reloading correctly, and it's
just the specific images that are a problem.

Updated

14 years ago
Depends on: 57607
No longer depends on: 121787

Comment 12

14 years ago
*** Bug 167514 has been marked as a duplicate of this bug. ***

Comment 13

14 years ago
retargeting
Target Milestone: mozilla1.1alpha → Future

Comment 14

14 years ago
Now that Bug #57607 has been fixed, this may need to be checked again. Anyone
who grabs a nightly after tomorrow, could you please recheck this bug.
I uploaded a new stylesheet to my site which meant obvious changes in colours,
images, etc. The stylesheet replaced the old file upon being uploaded.

I reloaded the page, no effect. I force-reloaded the page (both Ctrl-F5 and
Shift-Reload), no effect. I cleared the cache then force-reloaded some more -
still no effect.

Only by viewing the CSS file directly and reloading it could I cause the new
style to show itself. (I didn't attempt closing and reopening the browser)

I had assumed that clearing the cache would cause absolutely everything to be
reloaded on the next request for it.

(This may be a different bug, but I couldn't find a better one)

(Firefox 20040411)

Comment 16

13 years ago
I can add to this with the case I am handling currently. I created a dynamic
background-image CSS tag with php that is triggered by the existence of a URL var. 
Logic:
if var then background-image: x 
if !var then background-image: y

This worked for an indeterminant amount of time and now it does not. The browser
is stuck displaying background-image: x

I have closed the session, started a new session, shift Reload, all of the
tricks and nothing works. I have yet to attempt restarting my machine but that's
about the only avenue I have yet to try.

Firefox 1.0PR
Windows XP SP1

Cheers, Miro

Comment 17

13 years ago
(In reply to comment #16)

Please disregard. I am an idiot.

> I can add to this with the case I am handling currently. I created a dynamic
> background-image CSS tag with php that is triggered by the existence of a URL
var. 
> Logic:
> if var then background-image: x 
> if !var then background-image: y
> 
> This worked for an indeterminant amount of time and now it does not. The browser
> is stuck displaying background-image: x
> 
> I have closed the session, started a new session, shift Reload, all of the
> tricks and nothing works. I have yet to attempt restarting my machine but that's
> about the only avenue I have yet to try.
> 
> Firefox 1.0PR
> Windows XP SP1
> 
> Cheers, Miro

Comment 18

13 years ago
Could someone attach a testcase? The URL doesn't work for me.

Updated

13 years ago
Assignee: pavlov → jdunn
QA Contact: tpreston → core.layout.images
Assignee: jdunn → nobody

Comment 19

10 years ago
(In reply to comment #4)
> can we get a testcase?

(In reply to comment #18)
> Could someone attach a testcase? The URL doesn't work for me.

Eduardo Costa, if you're reading this, can you attach a testcase... or anyone else who can reproduce the bug

qawanted keyword added
Keywords: qawanted

Comment 20

10 years ago
Created attachment 272558 [details]
testcase

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007071305 Minefield/3.0a7pre

I am not good with PHP foo, so you'll have to manually rename the images yourself for this testcase.

That said, this works for me both locally and on a server running Apache/2.0.52. Please reopen if you can reproduce.

->WORKSFORME

Updated

10 years ago

Comment 21

10 years ago
Created attachment 272559 [details]
testcase

Sorry, the previous testcase had incorrectly named images in it.
Attachment #272558 - Attachment is obsolete: true

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
Target Milestone: Future → ---

Comment 22

10 years ago
Adam, that 272559 attachment also WORKSFORME

Marking VERIFIED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.