Add ability to reverse ship-it/review status

RESOLVED DUPLICATE of bug 1195661

Status

MozReview
General
RESOLVED DUPLICATE of bug 1195661
2 years ago
2 years ago

People

(Reporter: gerald, Unassigned)

Tracking

Production

Details

(Reporter)

Description

2 years ago
After getting a "ship-it, with nits" on a patch (in bug 1242343), the nits were enough to encourage me to rewrite the patch. Therefore I wanted to reverse the "ship-it" to let/force the reviewer to do a full review again.

I didn't see any way to reverse the "r+" status. I tried to:
- Push again with "r?..." in the comment.
- Do a "Finish Review", leaving "Ship it" unselected, and publishing.
- Change "r+" to "r?" in Bugzilla.
- Look through the UI for some way to change the review status.

I think one/some/all of these status-change methods should be available.

Comment 1

2 years ago
Agreed, we're in the middle of implementing the first thing you suggested (probably with a prompt that can be overridden as an hg pref).  We might later add something in the UI as well, but the best way to do that is unclear at the moment.

Btw your third option (changing "r+" to "r?" in Bugzilla) does work, more or less, for now; the reviewer status will still stay green in MozReview, but at least the person will get bugmail re-requesting review.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1195661
You need to log in before you can comment on or make changes to this bug.