Error calling gen_test_packages_manifest.py when MOZ_PKG_PRETTYNAMES is set

RESOLVED FIXED in Firefox 47

Status

Testing
General
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: aleth, Assigned: aleth)

Tracking

Trunk
mozilla47
Points:
---

Firefox Tracking Flags

(firefox47 fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

2 years ago
Regression from bug 1239808.

Initially appeared to be simply due to a space in the filename, but Henrik commented:

When I check the full log file of that given job I can see the following:

http://archive.mozilla.org/pub/thunderbird/nightly/2016/03/2016-03-01-03-02-43-comm-central/comm-central-macosx64-nightly-bm86-build1-build7.txt.gz

/gen_test_packages_manifest.py \
      --jsshell jsshell-mac.zip \
      --dest-file dist//thunderbird-47.0a1.en-US.mac.test_packages.json \
      --common 'thunderbird-47.0a1.en-US.mac.common.tests.zip' \
      --common 'thunderbird-47.0a1.en-US.mac.common.tests.zip' --cppunittest 'thunderbird-47.0a1.en-US.mac.cppunittest.tests.zip' --mochitest 'thunderbird-47.0a1.en-US.mac.mochitest.tests.zip' --reftest 'thunderbird-47.0a1.en-US.mac.reftest.tests.zip' --talos 'thunderbird-47.0a1.en-US.mac.talos.tests.zip' --web-platform 'thunderbird-47.0a1.en-US.mac.web-platform.tests.zip' --xpcshell 'thunderbird-47.0a1.en-US.mac.xpcshell.tests.zip'

That's how I expect it to be called. Then the package-tests step is called a second time with the strange Daily prefix:

/gen_test_packages_manifest.py \
      --jsshell jsshell-mac.zip \
      --dest-file dist/mac/en-US//Daily 47.0a1.test_packages.json \
      --common 'Daily 47.0a1.common.tests.zip' \
      --common 'Daily 47.0a1.common.tests.zip' --cppunittest 'Daily 47.0a1.cppunittest.tests.zip' --mochitest 'Daily 47.0a1.mochitest.tests.zip' --reftest 'Daily 47.0a1.reftest.tests.zip' --talos 'Daily 47.0a1.talos.tests.zip' --web-platform 'Daily 47.0a1.web-platform.tests.zip' --xpcshell 'Daily 47.0a1.xpcshell.tests.zip'
(Assignee)

Updated

2 years ago
Blocks: 1239808
(Assignee)

Comment 1

2 years ago
I wonder if the apparent doubling is due to OS X unified builds.
(Assignee)

Comment 2

2 years ago
(In reply to aleth [:aleth] from comment #1)
> I wonder if the apparent doubling is due to OS X unified builds.

Looks like the doubling also appears on other platforms, but there the basename is 'daily-47.0a1'. The doubling is also not a recent regression.
(Assignee)

Comment 3

2 years ago
The one that fails has MOZ_PKG_PRETTYNAMES=1, from pretty-package-tests in mozilla/Makefile.in.
(Assignee)

Comment 4

2 years ago
Created attachment 8725906 [details] [diff] [review]
Followup Bug 1239808 to handle spaces in MOZ_TEST_PACKAGES_FILE

So I think we should probably take this so OS X builds with MOZ_PKG_PRETTYNAMES set work. However that won't resolve this bug, as I don't see why c-c builds should run pretty-package-test.
Attachment #8725906 - Flags: review?(jlund)
(Assignee)

Updated

2 years ago
Assignee: nobody → aleth
Status: NEW → ASSIGNED
(Assignee)

Comment 5

2 years ago
(In reply to aleth [:aleth] from comment #4)
> So I think we should probably take this so OS X builds with
> MOZ_PKG_PRETTYNAMES set work. However that won't resolve this bug, as I
> don't see why c-c builds should run pretty-package-test.

A bit of digging shows that this is due to there being no c-c equivalent of bug 1003475.
(Assignee)

Comment 6

2 years ago
Created attachment 8726337 [details] [diff] [review]
Only test pretty names on comm train branches, not comm-central

This should port the behaviour from that bug for comm-*.
Attachment #8726337 - Flags: review?(jlund)
(Assignee)

Updated

2 years ago
Attachment #8725906 - Attachment is obsolete: true
Attachment #8725906 - Flags: review?(jlund)
(Assignee)

Comment 7

2 years ago
Comment on attachment 8725906 [details] [diff] [review]
Followup Bug 1239808 to handle spaces in MOZ_TEST_PACKAGES_FILE

Still need this as well of course.
Attachment #8725906 - Flags: review?(jlund)
(Assignee)

Updated

2 years ago
Attachment #8725906 - Attachment is obsolete: false
(Assignee)

Updated

2 years ago
Component: Build Config → General
Product: Thunderbird → Testing
(Assignee)

Updated

2 years ago
Summary: Error calling gen_test_packages_manifest.py → Error calling gen_test_packages_manifest.py on comm-central
(Assignee)

Comment 8

2 years ago
(In reply to aleth [:aleth] from comment #6)
> Created attachment 8726337 [details] [diff] [review]
> Only test pretty names on comm train branches, not comm-central
> 
> This should port the behaviour from that bug for comm-*.

Of course, the downside of taking this patch would be that prettynames bugs like this one would only be discovered once the offending patch hits aurora.
(Assignee)

Updated

2 years ago
Summary: Error calling gen_test_packages_manifest.py on comm-central → Error calling gen_test_packages_manifest.py when MOZ_PKG_PRETTYNAMES is set

Comment 9

2 years ago
Comment on attachment 8726337 [details] [diff] [review]
Only test pretty names on comm train branches, not comm-central

Review of attachment 8726337 [details] [diff] [review]:
-----------------------------------------------------------------

code wise, looks good. but I agree that this will have the side effect of not showing up failures for a while. depends on how often this target catches those and how often they happen.
Attachment #8726337 - Flags: review?(jlund) → review+

Updated

2 years ago
Attachment #8725906 - Flags: review?(jlund) → review+
(Assignee)

Comment 10

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/efae40ee27c8730b77490e0c5a2b5c2aabb418ed
Bug 1252809 - Followup Bug 1239808 to handle spaces in MOZ_TEST_PACKAGES_FILE. r=jlund
(Assignee)

Comment 11

2 years ago
(In reply to Jordan Lund (:jlund) from comment #9)
> code wise, looks good. but I agree that this will have the side effect of
> not showing up failures for a while. depends on how often this target
> catches those and how often they happen.

If I understand correctly, it would just mean such failures appear at the same time on comm-* as they do on mozilla-*. I guess we can try it and see...
(Assignee)

Comment 12

2 years ago
https://hg.mozilla.org/build/buildbot-configs/rev/18c0c4c9906496f5681db7f06d44a44010590950
Bug 1252809 - Only test pretty names on comm train branches, not comm-central. r=jlund

Comment 13

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/efae40ee27c8
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox47: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
You need to log in before you can comment on or make changes to this bug.