update Firefox 46 to use NSS 3.22.3

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: keeler, Assigned: kaie)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox46+ fixed, firefox47+ fixed)

Details

Attachments

(1 attachment)

There are some small changes we'd like to make to the version of NSS in Firefox 46, but since it's close to/in Beta, it would be best to make a branch of NSS with the changes we'd like and uplift that to 46. In particular, the compatibility change in bug 1243641 is what we'd like to include.
Assignee

Comment 1

3 years ago
Assignee: nobody → kaie
Assignee

Comment 2

3 years ago
Comment on attachment 8729548 [details]
beta46-to-nss-3.22.3.txt

Approval Request Comment
Required Compatibility fix found during testing.
If you don't approve this, we must disable the Extended-Master-Secret feature in Firefox 46.
Attachment #8729548 - Flags: approval-mozilla-beta?
Marking affected and tracking for 46.  
David or Kai, should this also uplift to 47? Or is this already fixed in 47? Thanks.
Comment on attachment 8729548 [details]
beta46-to-nss-3.22.3.txt

NSS fixes for 46. This should go into today's beta 2 build.
Attachment #8729548 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Assignee

Comment 5

3 years ago
Firefox 47 is already fixed.

You are giving me tough deadlines!
I'll try to get this done today.
Assignee

Comment 6

3 years ago
beta for firefox 46
https://hg.mozilla.org/releases/mozilla-beta/rev/382ab24a1a55

firefox 47 is already fixed, as it already uses a newer version of nss that already contains the fix that we want to pick up.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.