Followed installation instruction but can't access bugzilla from terminal

RESOLVED WORKSFORME

Status

()

Bugzilla
Documentation
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: seanjosephmcmahon, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.116 Safari/537.36

Steps to reproduce:

I followed the step here: http://bugzilla.readthedocs.org/en/latest/installing/quick-start.html


Actual results:

Everything worked as per guide ,(can login via lynx) but my server is in azure and not in a local intranet and I can't access it.  


Expected results:

Would have expected to enter my ip address, (40.127.99.16) and see the bugzilla login page.

Comment 1

2 years ago
Please elaborate and provide exact steps to reproduce the problem:
Which webserver are you running? How did you configure it?
Flags: needinfo?(seanjosephmcmahon)
(Reporter)

Comment 2

2 years ago
1. Launch azure 14.04 Ubuntu virtual machine
2. Follow exactly installation steps : http://bugzilla.readthedocs.org/en/latest/installing/quick-start.html
3. Login to bugzilla on vm using lynx
4. Attempt to login to bugzilla via azure virtual machine IP Address, (in my case 40.127.99.16)
5. Bugzilla login page does not appear
Flags: needinfo?(seanjosephmcmahon)

Comment 3

2 years ago
- What is the output of checksetup.pl?
- Which web server do you use? If there is none or it doesn't execute CGI scripts, this is a configuration problem.
- Is the IP address accessible?
(Reporter)

Comment 4

2 years ago
- What is the output of checksetup.pl?

I ran it again, this is the output:

f6t@f6:/var/www/html$ sudo ./checksetup.pl
* This is Bugzilla 5.0.2 on perl 5.18.2
* Running on Linux 3.19.0-49-generic #55~14.04.1-Ubuntu SMP Fri Jan 22 11:24:31 UTC 2016

Checking perl modules...
Checking for               CGI.pm (v3.51)     ok: found v3.64
Checking for           Digest-SHA (any)       ok: found v5.84_01
Checking for             TimeDate (v2.23)     ok: found v2.24
Checking for             DateTime (v0.75)     ok: found v1.06
Checking for    DateTime-TimeZone (v1.64)     ok: found v1.95
Checking for                  DBI (v1.614)    ok: found v1.63
Checking for     Template-Toolkit (v2.24)     ok: found v2.24
Checking for         Email-Sender (v1.300011) ok: found v1.300021
Checking for           Email-MIME (v1.904)    ok: found v1.925
Checking for                  URI (v1.55)     ok: found v1.60
Checking for       List-MoreUtils (v0.32)     ok: found v0.33
Checking for    Math-Random-ISAAC (v1.0.1)    ok: found v1.003
Checking for           File-Slurp (v9999.13)  ok: found v9999.19
Checking for              JSON-XS (v2.01)     ok: found v2.34

Checking available perl DBD modules...
Checking for               DBD-Pg (v2.7.0)    not found
Checking for            DBD-mysql (v4.001)    ok: found v4.025
Checking for           DBD-SQLite (v1.29)     ok: found v1.50
Checking for           DBD-Oracle (v1.19)     not found

The following Perl modules are optional:
Checking for                   GD (v1.20)     ok: found v2.46
defined(@array) is deprecated at /usr/share/perl5/Chart/Base.pm line 181.
        (Maybe you should just omit the defined()?)
defined(@array) is deprecated at /usr/share/perl5/Chart/Base.pm line 233.
        (Maybe you should just omit the defined()?)
Checking for                Chart (v2.4.1)    ok: found v2.4.6
Checking for          Template-GD (any)       ok: found v1.56
Checking for           GDTextUtil (any)       ok: found v0.86
Checking for              GDGraph (any)       ok: found v1.44
Checking for           MIME-tools (v5.406)    ok: found v5.505
Checking for          libwww-perl (any)       ok: found v6.05
Checking for             XML-Twig (any)       ok: found v3.44
Checking for          PatchReader (v0.9.6)    ok: found v0.9.6
Checking for            perl-ldap (any)       ok: found v0.58
Checking for          Authen-SASL (any)       ok: found v2.15
Checking for         Net-SMTP-SSL (v1.01)     ok: found v1.01
Checking for           RadiusPerl (any)       ok: found v0.24
Checking for            SOAP-Lite (v0.712)    ok: found v1.09
Checking for          XMLRPC-Lite (v0.712)    ok: found v0.717
Checking for             JSON-RPC (any)       ok: found v1.03
Checking for           Test-Taint (v1.06)     ok: found v1.06
Checking for          HTML-Parser (v3.67)     ok: found v3.71
Checking for        HTML-Scrubber (any)       ok: found v0.11
Checking for               Encode (v2.21)     ok: found v2.49
Checking for        Encode-Detect (any)       ok: found v1.01
Checking for          Email-Reply (any)       ok: found v1.204
Checking for HTML-FormatText-WithLinks (v0.13)     ok: found v0.14
Checking for          TheSchwartz (v1.07)     ok: found v1.07
Checking for       Daemon-Generic (any)       ok: found v0.82
Checking for             mod_perl (v1.999022) ok: found v2.000008
Checking for     Apache-SizeLimit (v0.96)     not found
Checking for        File-MimeInfo (any)       ok: found v0.22
Checking for           IO-stringy (any)       ok: found v2.110
Checking for      Cache-Memcached (any)       ok: found v1.30
Checking for  File-Copy-Recursive (any)       ok: found v0.38
Checking for           File-Which (any)       ok: found v1.09
Checking for              mod_env (any)       ok
Checking for          mod_expires (any)       ok
Checking for          mod_headers (any)       ok
Checking for          mod_rewrite (any)       not found
Checking for          mod_version (any)       ok
***********************************************************************
* OPTIONAL MODULES                                                    *
***********************************************************************
* Certain Perl modules are not required by Bugzilla, but by           *
* installing the latest version you gain access to additional         *
* features.                                                           *
*                                                                     *
* The optional modules you do not have installed are listed below,    *
* with the name of the feature they enable. Below that table are the  *
* commands to install each module.                                    *
***********************************************************************
*      MODULE NAME * ENABLES FEATURE(S)                               *
***********************************************************************
* Apache-SizeLimit * mod_perl                                         *
***********************************************************************
* APACHE MODULES                                                      *
***********************************************************************
* Some Apache modules allow to extend Bugzilla functionalities.       *
* These modules can be enabled in the Apache configuration file       *
* (usually called httpd.conf or apache2.conf).                        *
* - mod_headers, mod_env and mod_expires permit to automatically      *
*   refresh the browser cache of your users when upgrading Bugzilla.  *
* - mod_rewrite permits to write shorter URLs used by the REST API.   *
* - mod_version permits to write rules in .htaccess specific to       *
*   Apache 2.2 or 2.4.                                                *
* The modules you need to enable are:                                 *
*                                                                     *
*    mod_rewrite                                                      *
*                                                                     *
***********************************************************************
COMMANDS TO INSTALL OPTIONAL MODULES:

Apache-SizeLimit: /usr/bin/perl install-module.pl Apache2::SizeLimit


To attempt an automatic install of every required and optional module
with one command, do:

  /usr/bin/perl install-module.pl --all

Reading ./localconfig...

OPTIONAL NOTE: If you want to be able to use the 'difference between two
patches' feature of Bugzilla (which requires the PatchReader Perl module
as well), you should install patchutils from:

    http://cyberelk.net/tim/software/patchutils/

Checking for            DBD-mysql (v4.001)    ok: found v4.025
Checking for                MySQL (v5.0.15)   ok: found v5.5.47-0ubuntu0.14.04.1

Removing existing compiled templates...
Precompiling templates...done.
Fixing file permissions...
checksetup.pl complete.
(Reporter)

Comment 5

2 years ago
- Which web server do you use? If there is none or it doesn't execute CGI scripts, this is a configuration problem.

Apache2 as per the guide http://bugzilla.readthedocs.org/en/latest/installing/quick-start.html
(Reporter)

Comment 6

2 years ago
- Is the IP address accessible?

I can SSH into it, so it is accessible.

Comment 7

2 years ago
(In reply to seanjosephmcmahon from comment #6)
> - Is the IP address accessible?
> 
> I can SSH into it, so it is accessible.

I mean the web server, not the ssh server. Is Apache running and working?
(Reporter)

Comment 8

2 years ago
Yes. Seems to be fine.

$ ps aux|grep apac
root      2458  0.0  0.2  80972  7772 ?        Ss   15:11   0:00 /usr/sbin/apache2 -k start
www-data  2461  0.0  0.1  79756  3800 ?        S    15:11   0:00 /usr/sbin/apache2 -k start
www-data  2462  0.0  0.2 370112  8552 ?        Sl   15:11   0:05 /usr/sbin/apache2 -k start
www-data  2463  0.0  0.2 370112  8552 ?        Sl   15:11   0:05 /usr/sbin/apache2 -k start
f6t       9517  0.0  0.0  10472  2184 pts/0    S+   20:33   0:00 grep

Comment 9

2 years ago
Please try to access your Bugzilla installation from a supported web browser, like Chrome, Firefox or IE11. Lynx is unsupported (I know the doc says to test your website with Lynx. Will change that). Also look at your apache error log to see if an error is thrown.
(Reporter)

Comment 10

2 years ago
It's a command line virtual machine, so that why I used lynx to validate.

Chrome and IE11 will not work.  Feel free to check the site yourself. 40.127.99.16

My understanding is that there is a problem between running in intranet and internet mode? 

Nothing in the error log of note:

[Thu Mar 03 15:11:39.424403 2016] [mpm_event:notice] [pid 2458:tid 140472064210816] AH00489: Apache/2.4.7 (Ubuntu) mod_perl/2.0.8 Perl/v5.18.2 configured -- resuming normal operations
[Thu Mar 03 15:11:39.424487 2016] [core:notice] [pid 2458:tid 140472064210816] AH00094: Command line: '/usr/sbin/apache2'
 

No errors for 10 hours....
(In reply to seanjosephmcmahon)
> - Is the IP address accessible?
> I can SSH into it, so it is accessible.
> It's a command line virtual machine, so that why I used lynx to validate.

you're testing from localhost.  i suspect the problem here is http connections from the internet are blocked to your host.

what actually happens when you connect from outside that server on port http?
if you get a timeout it's likely an firewall/nat/forwarding issue, not a bugzilla issue.
(Reporter)

Comment 12

2 years ago
Byron,

Thanks so much.  I added the security rules to azure and hey presto I can access bugzilla.

It might be worth adding this in the documentation as this is not a requirement for wordpress and hence I forgot, presumably others could for get too?

Thanks again,

Seán

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.