Closed Bug 1253468 Opened 4 years ago Closed 4 years ago

Buttons in footer of very long Bootstrap modal not clickable in Win Firefox 33+

Categories

(Core :: Layout: Form Controls, defect)

44 Branch
Unspecified
Windows
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1217012
Tracking Status
firefox44 --- affected
firefox45 --- unaffected
firefox46 --- unaffected
firefox47 --- unaffected

People

(Reporter: mozilla, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: regressionwindow-wanted)

Attachments

(1 file)

Attached file Copy of JS Bin example
Original Bootstrap issue: https://github.com/twbs/bootstrap/issues/19390

Affected OSes: Windows 7, 8.1, 10
(Earlier Windows versions haven't been tested. Doesn't repro on Mac OS X.)

Works fine in Firefox <=32.
Broken in Firefox >=33. Still broken in latest Firefox 44.0.2.

Steps to reproduce:
1. Open http://output.jsbin.com/rogixax/1/quiet in Firefox 44 on Windows.
2. Click the blue button.
3. Wait for the modal to appear.
4. Scroll to the bottom of the page.
5. Hover over the "Close" button.
5. Click the "Close" button.

Expected results:
The button should receive :hover styling when hovered over.
When the button is clicked, the modal should close.

Actual results:
The <button> appears to be treated as if it were a non-interactive element.
It doesn't receive :hover styling when hovered over.
Clicking on it multiple times results in its inner text being highlighted, as if it were a <span>.
If you open Developer Tools, the button cannot be selected using the Inspector's "pick an element by clicking on it" tool. The modal's main content <div> is selected instead.

Other notes:
This bug only occurs when the modal contains a *lot* of content and is thus very tall.
This bug hasn't been reproduced in any other browser, and old versions of Firefox aren't affected, so we believe there's a bug in Firefox itself that was introduced in Firefox 33.
The bug appears to be Windows-specific. I could not reproduce it on Mac OS X 10.11.3.
This seems to be fixed on 45.0RC1
Bug 1217012 fixed this.
Indeed!
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Version: Trunk → 44 Branch
Duplicate of bug: 1217012
You need to log in before you can comment on or make changes to this bug.