Closed Bug 1253899 Opened 6 years ago Closed 5 years ago

Firefox mobile does not sync passwords

Categories

(Firefox for Android Graveyard :: Android Sync, defect)

Firefox 51
ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 711636

People

(Reporter: gabriele, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160209234513
Firefox for Android

Steps to reproduce:

Hello there,

I have Firefox installed on my desktop, sync active and working. It is syncing correctly with another desktop.

1. I have installed Firefox Mobile for Android 44.0.2
2. I have set up a master password
3. I have configured the sync account
4. I have checked "sync passwords" and "sync favorites" options
5. I have started a sync

When I've seen it didn't work, I have uninstalled the app and tried again from scratch: same result.


Actual results:

My favorites are correctly synced, passwords are empty.


Expected results:

Both favorites and passwords are synced.
Component: Sync → Android Sync
Product: Firefox → Android Background Services
Version: 44 Branch → Firefox 44
https://addons.mozilla.org/en-US/firefox/addon/about-sync/ should help confirm if the missing passwords are on the server.
It looks all good to me with this add-on. The sync works fine between all my desktops, I think my issue is more like bug 1073680 that they synced, but don't update anymore/consistently(!?).

Gabriele, does it generally work now for you?
Flags: needinfo?(gabriele)
I have installed FF Beta 51.0b9 from Play Store, connected it to my Firefox Sync account, waited for it to finish sync.

It now says it has last synced 2 minutes ago. If I go in privacy/password manager, the page is still empty. If I try to login to a website where I know I have a saved password, it does not prompt me for master password or retrieve it.

In conclusion, nothing changed in the reported behaviour.

(Yes, the passwords are on the server because the notebook correctly syncs them)
(In reply to Albert Scheiner [:alberts] from comment #3)
> It looks all good to me with this add-on. The sync works fine between all my
> desktops, I think my issue is more like bug 1073680 that they synced, but
> don't update anymore/consistently(!?).
> 
> Gabriele, does it generally work now for you?

Please see Comment 4.
Flags: needinfo?(gabriele)
OS: Unspecified → Android
Hardware: Unspecified → ARM
Version: Firefox 44 → Firefox 51
Duplicate of this bug: 1073680
I do not expect password sync to work on Android if a master password is set. Bug 711636.

You don't need a master password on Android on a modern non-rooted device.

If you have MP enabled, and disabling it gets you unblocked, then this can be duped to Bug 711636.
I think the MP is a good and necessary safety measure, but maybe I'm just paranoid. Anyway, I don't really want to try syncing with MP disabled.
I just disabled MP, manually pushed sync, but my passwords are still from several months ago and didn't yet geht updated.
You should know that MP is a strictly local feature: your logins are encrypted with your FxA keys when in transit and on the Sync server. The only reason to use MP is if you have no OS disk sandboxing and no OS disk encryption. Even then, MP is relatively weak; its main role these days is to act as a PIN lock to stop guests or children from accessing your passwords.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 711636
Product: Android Background Services → Firefox for Android
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.