Closed Bug 1254020 Opened 4 years ago Closed 4 years ago

Dropdowns and scrollbars look awful with Windows on Retina display

Categories

(Core :: Widget: Win32, defect)

Unspecified
Windows
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla48
Tracking Status
firefox47 --- fixed
firefox48 --- verified

People

(Reporter: aklotz, Assigned: jfkthame)

References

(Depends on 2 open bugs)

Details

Attachments

(2 files)

Macbook Pro Retina, Windows 10 bootcamp

Scrollbars and dropdown buttons are really tiny. Looks like they aren't being scaled to high DPI.
Could you attach a screenshot of what you're seeing? Thanks.
Flags: needinfo?(aklotz)
On a real win10 box with fullHD display and 125% upscale I don't see any problems.  Screenshot would help tho.
:aklotz, could you attach a screenshot showing examples of this problem with latest Nightly, please? I haven't seen it on my windows hi-dpi system, but wonder if it's somehow a bootcamp issue...
I was able to repro after having Fx maximized on a lower dpi external monitor, and then unplugging the monitor. When Fx was moved to my retina, it continued to use the previous dimensions for the themed controls.

I'll upload a screenshot when I get a chance.
Flags: needinfo?(aklotz)
I was able to reproduce this on a Windows 10 and 8.1 machine with low and hi-dpi monitors. 
Maximized FF on hi-dpi screen, unplugged hi-dpi screen, FF switched to low-dpi. The other way around (unplug the low-dpi screen) the issue did not reproduce.
Forgot to mention that I used latest Nightly and DevEdition to test this. I also went ahead and test with old Nightlys and I got this: 

Nightly 2016-01-12 - not affected (per-monitorDPI was not enabled)
Nightly 2016-01-14 - Affected (per-monitorDPI enabled)
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #5)
> Created attachment 8733899 [details]
> Screenshot showing the issue
> 
> I was able to reproduce this on a Windows 10 and 8.1 machine with low and
> hi-dpi monitors. 
> Maximized FF on hi-dpi screen, unplugged hi-dpi screen, FF switched to
> low-dpi. The other way around (unplug the low-dpi screen) the issue did not
> reproduce.

Aha, thanks; I've been able to reproduce this, too.

Which direction it reproduces is dependent on which of the screens was your primary monitor, I think. I've been able to trigger the problem in both directions (resulting in either oversized or miniature controls), by varying my display configuration.
The issue here arises when the system's primary display is removed, leaving a single display whose DPI does not match the (fixed-until-signout) Windows system scaling. Because of cases like this, we can't short-circuit the theme-scale computation even if there's only a single monitor present, as it may nevertheless differ from the system DPI.
Attachment #8734317 - Flags: review?(VYV03354)
Assignee: nobody → jfkthame
Status: NEW → ASSIGNED
Attachment #8734317 - Flags: review?(VYV03354) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/05cf733d5b26369caeca4550a0d33e9fd099b622
Bug 1254020 - Always compute theme scaling factor when per-monitor dpi aware, even if only a single display is currently present. r=emk
Comment on attachment 8734317 [details] [diff] [review]
Always compute theme scaling factor when per-monitor dpi aware, even if only a single display is currently present

Approval Request Comment
[Feature/regressing bug #]: 890156 (per-monitor dpi)

[User impact if declined]: potential for incorrect scaling of controls after certain types of change to display configuration

[Describe test coverage new/current, TreeHerder]: manually

[Risks and why]: minimal, just removing a shortcut that is not always valid

[String/UUID change made/needed]: none
Attachment #8734317 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/05cf733d5b26
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
Hi Aaron, could you please verify the fix on a latest Nightly build? Thanks!
Flags: needinfo?(aklotz)
Comment on attachment 8734317 [details] [diff] [review]
Always compute theme scaling factor when per-monitor dpi aware, even if only a single display is currently present

per-monitor DPI related fix, Aurora47+
Attachment #8734317 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
LGTM. Thanks!
Flags: needinfo?(aklotz)
Depends on: 1316387
Depends on: 1316717
No longer depends on: 1316387
Depends on: 1342821
Depends on: 1419830
You need to log in before you can comment on or make changes to this bug.