select form control restores selections on back based on element's position

RESOLVED DUPLICATE of bug 95622

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 95622
17 years ago
17 years ago

People

(Reporter: Christian Reis, Assigned: John Keiser (jkeiser))

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Problem (assumes you have a select control in a submittable form, such as
query.cgi):

have a select form control with MULTIPLE
select a number of the form control's elements
submit form
press back button

Results:
control's contents are restored. This is expected. However, the problem lies in
the fact that they are restored based on their original _position_ and not their
_contents_. This usually isn't a problem _unless_ the select control is filled
in dynamically, in which case the wrong selections will be restored.

This is a pretty tricky bug to reproduce, but because Bugzilla's query.cgi is
the select control burn-in test, we've uncovered it.

jkeiser has given me some feedback on it, and i'm looking at the code

Comment 2

17 years ago
-->
Assignee: rods → jkeiser
*** Bug 128013 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

17 years ago
kiko, any traction here?
Target Milestone: --- → Future
(Assignee)

Comment 5

17 years ago
Duping to bug 95622 since that one has the adt and nsbeta1 notations

*** This bug has been marked as a duplicate of 95622 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.