Closed Bug 1254463 Opened 4 years ago Closed 3 years ago

Visual glitches in menus with intel drivers

Categories

(Core :: Graphics, defect)

44 Branch
All
Windows 10
defect
Not set
60

Tracking

()

RESOLVED WORKSFORME
Tracking Status
platform-rel --- +

People

(Reporter: ge3k0s, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: gfx-noted [platform-rel-Intel])

On my XPS 13 (200% dpi on Windows 10), when I open a bookmarks folder in the bookmarks toolbar, there are often visual glitches (black zones) that pop up here. It seems to be dpi related since it doesn't happen on my main build that is at 100%.
Blocks: windows-10
May be related to bug 1238340.
Summary: Visual glitches in bookmark menu on hdpi screens → Visual glitches in bookmark menus on hdpi screens
(In reply to Guillaume C. [:ge3k0s] from comment #0)
> It seems to be dpi related since it doesn't happen on my main build
> that is at 100%.

Is the main build also running on win10 ?

Black boxes are pretty much never theme-related, and almost always a gfx issue.

Can you provide the about:support gfx info from both the working and non-working places?

Does turning off hardware acceleration fix the issue on the hidpi machine?
Component: Theme → Graphics
Flags: needinfo?(ge3k0s)
Product: Firefox → Core
(In reply to :Gijs Kruitbosch from comment #2)
> (In reply to Guillaume C. [:ge3k0s] from comment #0)
> > It seems to be dpi related since it doesn't happen on my main build
> > that is at 100%.
> 
> Is the main build also running on win10 ?

Yes.
> Black boxes are pretty much never theme-related, and almost always a gfx
> issue.
>
> Can you provide the about:support gfx info from both the working and
> non-working places?

I'm not at home but here are the graphic info on my hidpi build :

Graphics
Adapter Description	Intel(R) HD Graphics 5500
Adapter Drivers	igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
Adapter RAM	Unknown
Asynchronous Pan/Zoom	none
Device ID	0x1616
Direct2D Enabled	true
DirectWrite Enabled	true (10.0.10586.0)
Driver Date	11-18-2015
Driver Version	20.19.15.4331
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Subsys ID	06651028
Supports Hardware H264 Decoding	Yes
Vendor ID	0x8086
WebGL Renderer	Google Inc. -- ANGLE (Intel(R) HD Graphics 5500 Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0

> Does turning off hardware acceleration fix the issue on the hidpi machine?

Yes it seems to solve it. Also note that the problem occurs with 100% dpi too on this config.
Flags: needinfo?(ge3k0s)
Pinging gfx folks for comment #3.

(Milan, please do let me know if new bugzilla focus stuff means I should just assume things will get looked at once moved into Core::Graphics and to stop needinfo'ing you :-) )
Flags: needinfo?(milan)
I must admit I'm not sure it's dpi related anymore.
(In reply to :Gijs Kruitbosch from comment #4)
> Pinging gfx folks for comment #3.
> 
> (Milan, please do let me know if new bugzilla focus stuff means I should
> just assume things will get looked at once moved into Core::Graphics and to
> stop needinfo'ing you :-) )

Yes, please, CC me on bugs that move into graphics, especially when they are older than a week when this move happens.  And use needinfo when you need more than to call my attention to it.
Flags: needinfo?(milan)
(In reply to Guillaume C. [:ge3k0s] from comment #5)
> I must admit I'm not sure it's dpi related anymore.

I'm guessing it could be related to bug 1253241.  Any chance you could get a regression range using mozregression (http://mozilla.github.io/mozregression/)?
(In reply to Milan Sreckovic [:milan] (PTO until 3/23) from comment #7)
> (In reply to Guillaume C. [:ge3k0s] from comment #5)
> > I must admit I'm not sure it's dpi related anymore.
> 
> I'm guessing it could be related to bug 1253241.  Any chance you could get a
> regression range using mozregression
> (http://mozilla.github.io/mozregression/)?

I will try in the next few days but I don't know if I'll find time to do it. FWIW the bug happens with e10s disabled and doesn't look like the screencast in bug 1253241.
Summary: Visual glitches in bookmark menus on hdpi screens → Visual glitches in menus on hdpi screens
I'm beginning to wonder if it's not related to intel drivers. Philipp IIRC you also have an XPS13. Could you try to reproduce this issue ? FWIW I'm on the first new gen of XPS13 (9343).
Flags: needinfo?(philipp)
Summary: Visual glitches in menus on hdpi screens → Visual glitches in menus with intel drivers
I've had the same issues on an XPS13 and a Surface Pro, both of which (I think) have Intel grpahics.
The issues have been gone for me since bug 1245765 landed in Nightly. They are still present in the release version.
Could you try to reproduce with a current Nightly?
Flags: needinfo?(philipp)
(In reply to Out of office until March 28! Philipp Sackl [:phlsa] (Firefox UX) please use needinfo from comment #10)
> I've had the same issues on an XPS13 and a Surface Pro, both of which (I
> think) have Intel grpahics.
> The issues have been gone for me since bug 1245765 landed in Nightly. They
> are still present in the release version.
> Could you try to reproduce with a current Nightly?

Yes the issue seems to be still present in latest Nightly. The windows repaint issue doesn't seem to be reproducible anymore, but the black glitches in menus appear from time to time.
Ok I've done a clean install of the last Intel drivers on my PC and the issue seems to be gone. I will wait a bit and close the bug in a few days if it's the case.
So my drivers were clearly corrupted. Sorry for the unnecessary noise here.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Ok for some unknown reasons the issue has reappeared...
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
I'm wondering whether it's related to the fact that a plugin (Flash player) is present on the page. It seems to happen only at this condition.
Whiteboard: gfx-noted → gfx-noted [platform-rel-Intel]
platform-rel: --- → ?
platform-rel: ? → +
Rank: 60
Can you still reproduce this issue? (We think it might be fixed)
Flags: needinfo?(ge3k0s)
(In reply to David Bolter [:davidb] from comment #16)
> Can you still reproduce this issue? (We think it might be fixed)

I've seen it recently a couple of times on Firefox 49, but I haven't tested Nighlty in a long while.
Flags: needinfo?(ge3k0s)
Can't reproduce anymore
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.