Allow specification of alerting properties in series signature

RESOLVED FIXED

Status

Tree Management
Perfherder
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: wlach, Assigned: wlach)

Tracking

(Blocks: 1 bug)

Details

Attachments

(1 attachment)

We should allow the user to tweak alerting thresholds and properties in the series. Specifically:

* Whether we should alert on this series or not, overriding defaults (e.g. in AWFY we want the reverse of the usual behaviour: alert on subtests, don't alert on summaries)
* % threshold for changes (Dromaeo should be higher e.g. see bug 1232270)
* Fore window / back window (for example, we want a much larger window for builds)

We could also possibly allow tweaking the t-threshold for alerting, but I'm not sure if we want to mess with that on the series level. Unless others have strong opinions (and arguments), let's leave that out for now
Duplicate of this bug: 1252990

Comment 2

a year ago
Created attachment 8728674 [details] [review]
[treeherder] wlach:1254595 > mozilla:master
Comment on attachment 8728674 [details] [review]
[treeherder] wlach:1254595 > mozilla:master

Quite a bit of code here, but most of it is boilerplate.
Attachment #8728674 - Flags: review?(jmaher)
Comment on attachment 8728674 [details] [review]
[treeherder] wlach:1254595 > mozilla:master

a few nits in the PR- please address them or help me understand.
Attachment #8728674 - Flags: review?(jmaher) → review-
Blocks: 1261969
Attachment #8728674 - Flags: review-
Comment on attachment 8728674 [details] [review]
[treeherder] wlach:1254595 > mozilla:master

Hey Joel, thanks for the feedback -- it encouraged me to expand testing of this feature, which I think was a good idea. I addressed your feedback in a separate commit, let me know what you think.
Attachment #8728674 - Flags: review?(jmaher)
Comment on attachment 8728674 [details] [review]
[treeherder] wlach:1254595 > mozilla:master

I don't see anything scary here!
Attachment #8728674 - Flags: review?(jmaher) → review+
Keywords: autoland

Comment 7

a year ago
Pull request has landed in master: https://github.com/mozilla/treeherder/commit/70d66ce6e66eeb46155a18543bd3e70bff27a303

Comment 8

a year ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/4da1e522efd57b76ed48763a48b084626e4c1be6
Bug 1254595 - Make alert generation parameters configurable per-series

Updated

a year ago
Keywords: autoland

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.