Closed Bug 1254963 Opened 6 years ago Closed 6 years ago

MSVC 2015 build fails with C2664

Categories

(Toolkit :: Crash Reporting, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla48
Tracking Status
firefox48 --- fixed

People

(Reporter: emk, Assigned: emk)

References

Details

Attachments

(1 file, 1 obsolete file)

You broke MSVC 2015 build once again. Please be careful when using BeginWriting() + Win32 API. Even if this is fixed, build still fails because dia2.h is not found.
Flags: needinfo?(aklotz)
Looks like C1083 is a regression from bug 623183.
Summary: MSVC 2015 build fails with C2664 and C1083 → MSVC 2015 build fails with C2664
Attached patch patch (obsolete) — Splinter Review
I hope I don't have to post yet another patch anymore...
Assignee: nobody → VYV03354
Status: NEW → ASSIGNED
Flags: needinfo?(aklotz)
Attachment #8728391 - Flags: review?(aklotz)
Comment on attachment 8728391 [details] [diff] [review]
patch

Review of attachment 8728391 [details] [diff] [review]:
-----------------------------------------------------------------

Do we have a better solution for this in the long term? It seems to me that casting all over the place is less than ideal.
Attachment #8728391 - Flags: review?(aklotz) → review+
(In reply to Aaron Klotz [:aklotz] (please use needinfo) from comment #3)
> Do we have a better solution for this in the long term? It seems to me that
> casting all over the place is less than ideal.

Creating a helper method to char16ptr_t?
Backed out for bustage.

Bustage: https://hg.mozilla.org/integration/mozilla-inbound/rev/5880d1449a79

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=c1dbec35e0c5
Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=23386486&repo=mozilla-inbound
15:05:09     INFO -  In file included from /builds/slave/m-in-lx-0000000000000000000000/build/src/obj-firefox/toolkit/crashreporter/Unified_cpp_crashreporter0.cpp:2:0:
15:05:09     INFO -  /builds/slave/m-in-lx-0000000000000000000000/build/src/toolkit/crashreporter/nsExceptionHandler.cpp: In function 'bool CrashReporter::BuildTempPath(PathStringT&)':
15:05:09     INFO -  /builds/slave/m-in-lx-0000000000000000000000/build/src/toolkit/crashreporter/nsExceptionHandler.cpp:1205:48: error: no matching function for call to 'BuildTempPath(wchar_t*&, int)'
15:05:09     INFO -  /builds/slave/m-in-lx-0000000000000000000000/build/src/toolkit/crashreporter/nsExceptionHandler.cpp:1205:48: note: candidates are:
15:05:09     INFO -  /builds/slave/m-in-lx-0000000000000000000000/build/src/toolkit/crashreporter/nsExceptionHandler.cpp:1178:1: note: size_t CrashReporter::BuildTempPath(char*, size_t)
15:05:09     INFO -  /builds/slave/m-in-lx-0000000000000000000000/build/src/toolkit/crashreporter/nsExceptionHandler.cpp:1178:1: note:   no known conversion for argument 1 from 'wchar_t*' to 'char*'
15:05:09     INFO -  /builds/slave/m-in-lx-0000000000000000000000/build/src/toolkit/crashreporter/nsExceptionHandler.cpp:1193:1: note: template<class CharT, unsigned int N> size_t CrashReporter::BuildTempPath(CharT (&)[N])
15:05:09     INFO -  /builds/slave/m-in-lx-0000000000000000000000/build/src/toolkit/crashreporter/nsExceptionHandler.cpp:1193:1: note:   template argument deduction/substitution failed:
15:05:09     INFO -  /builds/slave/m-in-lx-0000000000000000000000/build/src/toolkit/crashreporter/nsExceptionHandler.cpp:1205:48: note:   mismatched types 'CharT [N]' and 'wchar_t*'
15:05:09     INFO -  /builds/slave/m-in-lx-0000000000000000000000/build/src/toolkit/crashreporter/nsExceptionHandler.cpp:1201:1: note: template<class PathStringT> bool CrashReporter::BuildTempPath(PathStringT&)
15:05:09     INFO -  /builds/slave/m-in-lx-0000000000000000000000/build/src/toolkit/crashreporter/nsExceptionHandler.cpp:1201:1: note:   template argument deduction/substitution failed:
15:05:09     INFO -  /builds/slave/m-in-lx-0000000000000000000000/build/src/toolkit/crashreporter/nsExceptionHandler.cpp:1205:48: note:   candidate expects 1 argument, 2 provided
15:05:09     INFO -  gmake[5]: *** [Unified_cpp_crashreporter0.o] Error 1
15:05:09     INFO -  gmake[5]: Leaving directory `/builds/slave/m-in-lx-0000000000000000000000/build/src/obj-firefox/toolkit/crashreporter'
15:05:09     INFO -  gmake[4]: *** [toolkit/crashreporter/target] Error 2
Flags: needinfo?(VYV03354)
Attached patch patch v2Splinter Review
Attachment #8728391 - Attachment is obsolete: true
Flags: needinfo?(VYV03354)
Attachment #8728994 - Flags: review?(aklotz)
Attachment #8728994 - Flags: review?(aklotz) → review+
Blocks: VC14
https://hg.mozilla.org/mozilla-central/rev/432379400c1b
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
Blocks: 1257486
Duplicate of this bug: 1266672
Is this upliftable / should we uplift this?
Flags: needinfo?(VYV03354)
Will the official Firefox 47 be built with MSVC 2015? If not, I don't think uplift is necessary. But uplift is easy.
Flags: needinfo?(VYV03354)
You need to log in before you can comment on or make changes to this bug.