Dashlane turned off Remember search and form history and Remember logins

RESOLVED INVALID

Status

()

RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: v+mozbug, Unassigned)

Tracking

45 Branch
x86
Windows 10
Points:
---

Firefox Tracking Flags

(firefox46+ affected)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160303134406

Steps to reproduce:

Upgrade from 44 to 45


Actual results:

Remember search and form history got turned off
Remember logins got turned off

In one profile (at least), turning those settings back on still doesn't result in saved passwords being filled in.  They are still displayable in the password manager.


Expected results:

None of the actual results should have happened.
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86

Comment 1

3 years ago
Is it reproducible with a fresh profile under FF44 and only these custom privacy settings?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Maybe it's an issue with some add-ons.

NB: FF44 is avalaible here: http://ftp.mozilla.org/pub/firefox/releases/44.0.2/
You can install it in a folder and use it with a fresh profile to make the update without affecting your main install of Firefox.
Flags: needinfo?(v+mozbug)

Comment 2

3 years ago
Same here.
I created a fresh new profile and still form history & passwords are not being remembered.
Went back to FF 44.0.2 and it is working fine.

Updated

3 years ago
Component: Untriaged → Bookmarks & History

Updated

3 years ago
Component: Bookmarks & History → Form Manager
Product: Firefox → Toolkit
Hello Glenn and	Gaurav,

Can you please test in Safe Mode https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode?

If passwords show in the Firefox password manager dialog but don't fill in safe mode, also attach the password manager debug logging (from in safe mode): https://wiki.mozilla.org/Toolkit:Password_Manager/Debugging

Thanks
Flags: needinfo?(gauravkumar37)
(Reporter)

Comment 4

3 years ago
It seems that when I don't close FF before shutting down windows, that at the next bootup, when FF restores the session, then the 3 settings get toggled:

Remember search and form history got turned off
Remember logins got turned off
signon.autofillForms gets turned to false, rather than the default of true (not originally reported, but required to get things back to normal).

Shutting down FF and starting normally again doesn't cause the problem.
Flags: needinfo?(v+mozbug)

Comment 5

2 years ago
FF 46 was released today and this bug is still there. This is a critical bug.
I downloaded FF 46.0 and created a new profile.
Went to www.facebook.com/login and entered my username and password.
FF did not ask me to save my password.
Also, checked on my already present profile and that also had the same issue.
Since it was a new profile, Remember passwords was checked.
This bug first appeared in FF 45 and is now present in FF46. I even checked latest FF 47.xxx and it's still there.
Flags: needinfo?(gauravkumar37)

Comment 6

2 years ago
this might also be happening when trend micro passwordmanager is installed on your system...
Bug 1255848 and bug 1269556 may be dupes/related.
Matt, maybe this will help narrow down the issue here and in the duplicate bugs. I will also email a contact from Trend Micro. 

This may be a regression from 45.
status-firefox46: --- → affected
tracking-firefox46: --- → +
Flags: needinfo?(MattN+bmo)
(Reporter)

Comment 9

2 years ago
Philipp - I do not have trend micro passwordmanager (at least not by that or similar name) on my system. So while that may be _a_ cause for this behavior, it is not the _only_ cause.

I did have some other password manager that was preinstalled on my Acer system, and it popped up for the first time after some months of ignoring it... and my problems did start when it popped up.  As soon as I realized it modified the behavior of the browser's own password management, I uninstalled it (and forget the name :( ) and changed the settings back.

Then I was left with this problem. Did that password manager leave behind a "bomb" in Firefox somewhere? Where can such bombs be left? How can one eliminate them? Can a "bomb" act in the way described (only activating after a shutdown/restart of Windows)?

Comment 10

2 years ago
could you open a new question at https://support.mozilla.org/questions/new and include your troubleshooting data in the process? troubleshooting is easier done there than in a bug report & hopefully we can get to the bottom of your issue this way...
Maybe someone from trendmicro support can take a look too.
Flags: needinfo?(trendmicro-antivirus)
(Reporter)

Comment 12

2 years ago
I remembered the name of the password manager:  Dashlane.  How did I suddenly remember it?  I checked my extension list and there it was... I had removed it from _all_ profiles. How did it come back and get reinstalled, without me being notified?

So I broadened my search: Agent Ransack found:

C:\ProgramData\miaFE7F.tmp\data\OFFLINE\AEA2A66F\D79EF2CA\DashlaneUpgradeService.exe
C:\ProgramData\miaFE7F.tmp\data\OFFLINE\58D6B6A5\42B5D254\DashlaneWebService.dll
C:\ProgramData\miaFE7F.tmp\data\OFFLINE\8ACBD226\44BAD9A2\DashlaneDownloader.exe.config
C:\ProgramData\miaFE7F.tmp\data\OFFLINE\7102F685\42B5D254\DashlaneDownloader.exe
C:\ProgramData\miaFE7F.tmp\data\OFFLINE\66BDCEF0\42B5D254\DashlaneUtility.dll
C:\Users\Glenn\AppData\Local\Temp\avastBCLTMP\firefox\jetpack-extension@dashlane.com\ (empty folder)
C:\ProgramData\Microsoft\Windows\WER\ReportArchive\ (contains 495 items; 131 items are folders named like AppCrash_Dashlane.exe_993b82b7c82344d15436375b77a9646a0a84160_ca593068_1907b36b but the binary gibberish varies)
C:\Users\Glenn\AppData\Roaming\Mozilla\Firefox\Profiles\ancestry\extensions\jetpack-extension@dashlane.com.xpi (one of these for each profile I have)

All this was _after_ having once deleted Dashlane from all my profiles, and uninstalling it from the Apps & Programs list in Win10.  So I can only conclude that Dashlane password manager is more like a virus than a useful program. The only evidence that it is not quite like a virus is that "dashlane" was in so many file names. Of course, it may turn out that it also creates even more files without "dashlane" in the file name.

So perhaps the conclusion is that I was infected with Dashlane (sadly, by my computer vendor).

The real question now is did I really get rid of Dashlane this time, by deleting all the above files?

And second, did Acer infect me with anything else this annoying?

Neither of these are questions for Mozilla, I guess.
I can confirm that Dashlane does disable Firefox's built-in password manager and form history:

content/core.js:
> KWController.disableBrowserAutofill=function disableBrowserAutofill(){
>   this.saveBrowserAutofillSettings();
>   browserPrefs.set("signon.rememberSignons",false);
>   browserPrefs.set("signon.autofillForms",false);
>   browserPrefs.set("browser.formfill.enable",false)
> };

If anyone has this issue and doesn't have or never had Dashlane installed then please file a new bug in this component and include about:support output.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(trendmicro-antivirus)
Flags: needinfo?(MattN+bmo)
Resolution: --- → INVALID
Summary: upgrade to 45 turned off Remember search and form history and Remember logins → Dashlane turned off Remember search and form history and Remember logins
You need to log in before you can comment on or make changes to this bug.