Closed Bug 1255156 Opened 6 years ago Closed 6 years ago

Inspector shows invalid </col> ending tags in markup

Categories

(DevTools :: Inspector, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 820926

People

(Reporter: openjck, Unassigned)

Details

(Whiteboard: [btpp-fix-later])

Attachments

(3 files)

Steps to reproduce:

1. Load a page that uses a <col> element (see attachment)
2. Open the Inspector

Actual result:

The markup in the Inspector shows a </col> closing tag after each corresponding opening tag. The closing tag is invalid because <col> is a void element like <img> and <br>. See attachment.

Expected result:

The markup in the Inspector should not show any closing </col> closing tags. Chrome does this correctly. See attachment.
Attached file Page that uses <col>
Same with <img /> tags. Example URL:
data:text/html,<img src="http://buukkit.appspot.com/img/random.gif" />
I think there's a bug on file for this already, but I can't find it just now. I will look for it a bit more.
Assigning a priority in the meantime.
Priority: -- → P2
Whiteboard: [btpp-fix-later]
Same with <br />
data:text/html,<p>some<br />text</p>
Looks like bug 820926 is the one we're looking for. I'll mark this as a duplicate.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 820926
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.