failure to run talos job when adding new jobs from push with no jobs selected

RESOLVED DUPLICATE of bug 1253341

Status

RESOLVED DUPLICATE of bug 1253341
3 years ago
3 years ago

People

(Reporter: jmaher, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [talos_wishlist])

(Reporter)

Description

3 years ago
http://archive.mozilla.org/pub/firefox/try-builds/mozilla@kaply.com-6009eb63149d0dcacfa659b6d84a6f1eaa898c06/try-win64/try_win10_64_test-chromez-bm110-tests1-windows-build0.txt.gz

10:48:29     INFO - Running post-action listener: _resource_record_post_action
10:48:29    FATAL - Uncaught exception: Traceback (most recent call last):
10:48:29    FATAL -   File "C:\slave\test\scripts\mozharness\base\script.py", line 1765, in run
10:48:29    FATAL -     self.run_action(action)
10:48:29    FATAL -   File "C:\slave\test\scripts\mozharness\base\script.py", line 1707, in run_action
10:48:29    FATAL -     self._possibly_run_method(method_name, error_if_missing=True)
10:48:29    FATAL -   File "C:\slave\test\scripts\mozharness\base\script.py", line 1647, in _possibly_run_method
10:48:29    FATAL -     return getattr(self, method_name)()
10:48:29    FATAL -   File "C:\slave\test\scripts\mozharness\mozilla\testing\talos.py", line 357, in run_tests
10:48:29    FATAL -     options = self.talos_options(args=args, **kw)
10:48:29    FATAL -   File "C:\slave\test\scripts\mozharness\mozilla\testing\talos.py", line 253, in talos_options
10:48:29    FATAL -     options.extend(self.query_sps_profile_options())
10:48:29    FATAL -   File "C:\slave\test\scripts\mozharness\mozilla\testing\talos.py", line 173, in query_sps_profile_options
10:48:29    FATAL -     junk, junk, opts = self.buildbot_config['sourcestamp']['changes'][-1]['comments'].partition('mozharness:')
10:48:29    FATAL - IndexError: list index out of range
10:48:29    FATAL - Running post_fatal callback...

we are parsing a comment which doesn't exist.
(Reporter)

Updated

3 years ago
Blocks: 1088251
Whiteboard: [talos_wishlist]
(Reporter)

Comment 1

3 years ago
this has fixed code in a patch related to bug 1253341
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1253341
You need to log in before you can comment on or make changes to this bug.