bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Separate email notification pref for verified, closed bugs

RESOLVED WORKSFORME

Status

()

Bugzilla
Email Notifications
P4
enhancement
RESOLVED WORKSFORME
17 years ago
6 years ago

People

(Reporter: Jody McIntyre, Unassigned)

Tracking

Details

(Reporter)

Description

17 years ago
Bugzilla currently provides an email notification pref for bugs that are
resolved or verified.  I would like to separate this into 3 prefs, for resolved,
verified, and closed.  Personally, I like to know when bugs are resolved, but
when they are closed or verified doesn't really concern me, so I would like not
to get email in these cases.  Many other developers here at OEone feel the same way.

If I have time, I will submit a patch to 2.16 after it is released - it hardly
seems worthwhile to work on 2.14.x.

Updated

17 years ago
Depends on: 73665

Updated

17 years ago
Whiteboard: [blocker will fix]
Changing default owner of Email Notifications component to JayPee, a.k.a.
J. Paul Reed (preed@sigkill.com).  Jake will be offline for a few months.
Assignee: jake → preed
Statuses and status transitions are going to be customised shortly.  I'm not
sure how something like this could fit into the picture.  A checkbox for each
transition (or even destination status) seems a bit excessive.  As far as only
caring about resolutions or reopens, a checkbox to specify resolution changes
would handle that.

Why is this marked [blocker will fix] ?
Priority: -- → P4
Target Milestone: --- → Bugzilla 2.20

Comment 3

16 years ago
My team also would like to get email when bugs are resolved but not when they
are verified.  We are testing for release today and verifying over 300 fixed
bugs - this is going to be a *lot* of email (and the whole development team is
on the QA contact list).

Comment 4

15 years ago
*** Bug 152010 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
*** Bug 55108 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
*** Bug 201916 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
Those three dups aren't the same as this one.  I reopened bug 55108 and marked
the other two as dups of it.
Bugzilla 2.20 feature set is now frozen as of 15 Sept 2004.  Anything flagged
enhancement that hasn't already landed is being pushed out.  If this bug is
otherwise ready to land, we'll handle it on a case-by-case basis, please set the
blocking2.20 flag to '?' if you think it qualifies.
Target Milestone: Bugzilla 2.20 → Bugzilla 2.22

Updated

13 years ago
Assignee: preed → email-notifications
OS: Linux → All
QA Contact: mattyt-bugzilla → default-qa
Hardware: PC → All
Whiteboard: [blocker will fix]
Target Milestone: Bugzilla 2.22 → ---

Comment 9

6 years ago
This email no longer exists, so this is no longer an issue. As Matthew said in comment 2, bug statuses are no longer hardcoded, and so it no longer makes sense to have a separate email pref for verified and closed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.