All users were logged out of Bugzilla on October 13th, 2018

Linked, Blocked Images Should Display Something

RESOLVED DUPLICATE of bug 98554

Status

()

RESOLVED DUPLICATE of bug 98554
17 years ago
17 years ago

People

(Reporter: mozilla, Assigned: pavlov)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

Currently linked, blocked images are not displayed,
but neither is any indication that their positions
remain active. This leads to unwanted link activation
when users click on the "whitespace" still occupied.

I tend to trigger this behavior when using a mouse
click to refocus a window. This is also troubling
for sites containing sidebar advertisements that
fit within, but do not fill, document margins.
Idle clicking can lead to undesired document
requests.

Reproducible: Always

Steps to Reproduce:
-------------------
1. Visit site with linked images.
2. Block the image server delivering
   the linked images (I use slashdot.org)
3. Reload document. 
4. Notice that linked images are hidden,
   but still active.

Actual Results:
---------------
Images were blocked. Links remained
active. I, as a user, had to recall
from memory where active areas of
"whitespace" remained.

Expected Results:
-----------------
Mozilla should have indicated where
active areas remain even after images
positioning those areas are blocked.

Possible Solutions:
-------------------
Possible solutions include display of an
image's ALT or TITLE attribute values and/or
placing a border around linked images that
have been blocked. A more drastic solution
would be to deactivate links for blocked
images. I don't think the latter is a good
solution, as I (at least) use blocked images
for navigational purposes (e.g., Slashdot
logo).
(Reporter)

Comment 1

17 years ago
Damn. Duplicate of <a
href="http://bugzilla.mozilla.org/show_bug.cgi?id=98554">Bug 98554</a>.
Sometimes I could kick myself when I trust a term search too much.

*** This bug has been marked as a duplicate of 98554 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.