Closed Bug 1255529 Opened 4 years ago Closed 4 years ago

File, line and column should all be linkable in the Frame component

Categories

(DevTools :: Shared Components, defect, P1)

48 Branch
defect

Tracking

(firefox47 unaffected, firefox48 fixed)

RESOLVED FIXED
Firefox 48
Tracking Status
firefox47 --- unaffected
firefox48 --- fixed

People

(Reporter: jsantell, Assigned: jsantell)

References

(Blocks 2 open bugs)

Details

(Keywords: regression, Whiteboard: [btpp-fix-now])

Attachments

(1 file)

Currently only the filename is clickable -- all of it should be.
Priority: -- → P1
r? Nick for frame changes, r? bgrins for style changes. The entire location (source:line:column) is now underlined/clickable. Some extra work needed because we don't want the function name or host name clickable in the memory tool, and to still get the abbreviated file name in the console.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=4036935a2c50
Attachment #8729708 - Flags: review?(nfitzgerald)
Attachment #8729708 - Flags: review?(bgrinstead)
Attachment #8729708 - Flags: review?(nfitzgerald) → review+
Brian clarified that this is a P1 because it is a regression.
Keywords: regression
Comment on attachment 8729708 [details] [diff] [review]
1255529-frame.patch

Review of attachment 8729708 [details] [diff] [review]:
-----------------------------------------------------------------

Works for me, thanks
Attachment #8729708 - Flags: review?(bgrinstead) → review+
https://hg.mozilla.org/mozilla-central/rev/24ff79c5fb01
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
Version: unspecified → 48 Branch
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.