[en-GB] "XML Parsing Error: undefined entity" in browser.xul when starting Firefox 46 beta 1 en-GB

RESOLVED DUPLICATE of bug 1255811

Status

()

Core
XUL
--
critical
RESOLVED DUPLICATE of bug 1255811
2 years ago
2 years ago

People

(Reporter: spaceshipgalore, Unassigned)

Tracking

({regression})

46 Branch
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8729187 [details]
firefoxbug.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.87 Safari/537.36

Steps to reproduce:

I have firefox 45 x64 ESR en-GB installed, when i upgrade to v46 beta 1 x64 en-GB i get an error.

I have all extensions disabled in firefox 45 so that isn't the problem. I have about 50 tabs that are set to load on startup, each tab loads at once rather than when you select each tab.


Actual results:

A screenshot of the error is attached to this bug report. If i close the window it closes firefox.exe. Running firefox in safe-mode does not stop the message from appearing either.


Expected results:

I should have been able to upgrade successfully. I made a thread about it here and there is another guy with the same problem in that thread: http://forums.mozillazine.org/viewtopic.php?f=23&t=2994077&p=14536829#p14536829
(Reporter)

Updated

2 years ago
Severity: normal → critical

Comment 1

2 years ago
Do you have simple steps to reproduce it easily? (add-ons to install, websites to open etc)
(Reporter)

Comment 2

2 years ago
(In reply to Loic from comment #1)
> Do you have simple steps to reproduce it easily? (add-ons to install,
> websites to open etc)

I have all extensions disabled so that isn't the problem. I don't believe that the websites matter either considering the error message. Just use Win 10 x64 with firefox 45 ESR en-GB x64 open lots of tabs, change the firefox settings so that previous tabs are loaded when firefox starts and have the tabs auto load instead of click to load. Both of those are in the settings GUI. Then upgrade to firefox 46 beta 1 x64 en-GB and you should get this error message hopefully. Another guy on the mozillazine forum gets the exact same bug.

Comment 3

2 years ago
How do you upgrade from 45 ESR to 46 Beta, these versions are on different channel?
(Reporter)

Comment 4

2 years ago
(In reply to Loic from comment #3)
> How do you upgrade from 45 ESR to 46 Beta, these versions are on different
> channel?

Yes they are on a different channel. I installed the installer from: https://ftp.mozilla.org/pub/firefox/releases/46.0b1/win64/en-GB/Firefox%20Setup%2046.0b1.exe

Comment 5

2 years ago
Ok, so you have 2 installs of Firefox, 45 ESR and Beta 46, sharing the same profile?
(Reporter)

Comment 6

2 years ago
(In reply to Loic from comment #5)
> Ok, so you have 2 installs of Firefox, 45 ESR and Beta 46, sharing the same
> profile?

yes, i overwrite the install directory when i install v46 beta 1. I have done this with other versions of stable, esr and beta before and never had a problem until v46 beta 1.

Updated

2 years ago
Duplicate of this bug: 1255749

Comment 8

2 years ago
2 reports, let's track this regression.
status-firefox46: --- → affected
tracking-firefox46: --- → ?
Keywords: regression, regressionwindow-wanted
Summary: error message after upgrading to firefox 46 beta 1 from v45 → "XML Parsing Error: undefined entity" in browser.xul after upgrading to firefox 46 beta 1 from v45

Updated

2 years ago
Component: Untriaged → XUL
Product: Firefox → Core
Status: UNCONFIRMED → NEW
Has Regression Range: --- → no
Has STR: --- → yes
status-firefox45: --- → unaffected
Ever confirmed: true

Comment 9

2 years ago
I also upgraded from v45.0RC2 (which is the same as the official v45.0 release) and got the same error. I'm using Windows 10 (build 10240, 64 bit). I did the upgrade by extracting from the v46.0b1 64 bit setup executable for the en-GB locale (downloaded from the same URL in comment 4) and overwriting contents of the v45.0 program directory. I then tried deleting my profile directory and starting from scratch, but Firefox still fails with the same error message, so this issue is reproducible even with a clean profile.

However, when I install the en-US locale version of 46.0b1 instead, using the same method, Firefox starts properly and my v45.0 profile also works flawlessly with all my addons, tab groups and session info intact.

In summary, there seems to be a problem with the en-GB localization of the v46.0b1 release.

Comment 10

2 years ago
To be sure of the STR: if I install en-GB 46.0b1 with a new profile, I can reproduce the issue by just starting the build?
Flags: needinfo?(utkualtunkaya)

Comment 11

2 years ago
(In reply to Loic from comment #10)
> To be sure of the STR: if I install en-GB 46.0b1 with a new profile, I can
> reproduce the issue by just starting the build?

Yes, indeed. When I switch between en-GB and en-US, with or without clearing the profile directory, en-US 46.0b1 always works and en-GB 46.0b1 always fails.
Flags: needinfo?(utkualtunkaya)

Comment 12

2 years ago
Ok, I confirm the bug by just installing and starting https://ftp.mozilla.org/pub/firefox/releases/46.0b1/win64/en-GB/Firefox%20Setup%2046.0b1.exe with a new profile.
Keywords: regressionwindow-wanted
Summary: "XML Parsing Error: undefined entity" in browser.xul after upgrading to firefox 46 beta 1 from v45 → [en-GB] "XML Parsing Error: undefined entity" in browser.xul when starting Firefox 46 beta 1 en-GB

Comment 13

2 years ago
flod, any idea about someone to contact to look for this bug about the en-GB localized build?
Flags: needinfo?(francesco.lodolo)
This is due to bug 1255811.

Localized builds of 46.0b1 should not be offered as download or automatic update, but I guess there's not much to be done for manual downloads.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(francesco.lodolo)
Resolution: --- → DUPLICATE
Duplicate of bug: 1255811
status-firefox45: unaffected → ---
status-firefox46: affected → ---
tracking-firefox46: ? → ---
You need to log in before you can comment on or make changes to this bug.