Awesomebar has gotten slow

RESOLVED DUPLICATE of bug 342913

Status

()

Firefox
Address Bar
P2
normal
RESOLVED DUPLICATE of bug 342913
2 years ago
a year ago

People

(Reporter: evilpie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
See this attached video. Just entering "gecko" actually shows the right result, but finishing with "gecko hook" takes 2 or 3 seconds for something to appear. This started happening to me all the time for different queries and I am starting to dread searching for something in the awesome bar. 

I recently pruned my history before October last year in the hope of improving this, but it has only helped temporarily.

I am happy to help debugging this is any way, ping me on irc.
(Reporter)

Comment 1

2 years ago
Created attachment 8729234 [details]
recording.webm
hm, that could happen if the result has a really low frecency value... but it should not happen often...
Maybe you could try (after a backup) to run https://addons.mozilla.org/en-US/firefox/addon/places-maintenance/
also, please check the frecency value of that entry in the database, you can use Sqlite Manager add-on.
(Reporter)

Comment 4

2 years ago
Ok just tried Places Maintenance and it seemed to have helped a lot in this case. Sadly it's still not as quick as it used to be. I will continue using this profile and report if there any new problems.
(Reporter)

Comment 5

2 years ago
Yeah, so I used this profile for two days and I am back to square one. I am using my fresh profile now, because it just feels so much smoother.

Updated

a year ago
Priority: -- → P2
Whiteboard: [fxsearch]
Unfortunately, while we will keep working on performance, this bug by itself is not actionable.
We introduced a bunch of improvements in 49 and 50 for the problem, and we are actively working on shrinking places.sqlite.
We are also again investigating the possibility of a fulltextindex that would definitely solve this.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 342913
You need to log in before you can comment on or make changes to this bug.