tabs converted to newline

VERIFIED DUPLICATE of bug 144188

Status

MailNews Core
Composition
--
major
VERIFIED DUPLICATE of bug 144188
16 years ago
10 years ago

People

(Reporter: ravi, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
i use mail in plaintext mode with format=flowed disabled.
in some cases, mailnews is converting tabs to newlines
(od shows \r\n). this does not happen to all tabs though.
i am trying to figure out why it happens in certain cases.

here's how to reproduce:

open up mailnews and start a new message. enter a table
such as the below using tabs to separate columbs:

        col1      col2
row1    val1.1    val1.2
row2    val2.1    val2.2

send the message. on receipt, it shows up as below:

 col1	col2
row1
val1.1
val1.2
row2
val2.1
val2.2

in the above its not that the columns are being wrapped
around. the source actually contains a "\r\n" after each
column!

if i just put tabs in the middle of a sentence, however,
this strange behaviour does not happen. the tabs are left
intact.

Comment 1

16 years ago
I make this a duplicate of Bug 144188.
Because I commented many in Bug 144188. sorry.

*** This bug has been marked as a duplicate of 144188 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
verified as dup 
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.