Add another test for calling ServiceWorkerRegistration.showNotification

RESOLVED FIXED in Firefox 48

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: bzbarsky, Assigned: bzbarsky)

Tracking

Trunk
mozilla48
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox48 fixed)

Details

Attachments

(1 attachment)

No description provided.
backed this out for perma test failures like https://treeherder.mozilla.org/logviewer.html#?job_id=23532088&repo=mozilla-inbound starting with this push
Flags: needinfo?(bzbarsky)
I have no idea why this particular change caused that, other than the fact that the u2f tests are broken by design...  I filed bug 1255784 on them.

But why would this test have affected them at all?  The u2f tests run in M12 on that platform ("Android 2.3 API9 opt") and serviceworker tests, including the one I added run in M13...

The answer is that without my patch M12 runs dom/u2f/tests/test_util_methods.html and M13 runs, in order, dom/u2f/tests/test_frame.html and dom/u2f/tests/test_no_token.html.

With my patch, on the other hand, M12 runs, in order, dom/u2f/tests/test_no_token.html and dom/u2f/tests/test_util_methods.html while M13 runs dom/u2f/tests/test_frame.html.

So it sounds like test_no_token depends on test_frame running before it or something.
Depends on: 1255784
Flags: needinfo?(bzbarsky)
Flags: needinfo?(bzbarsky)
Flags: needinfo?(bzbarsky)

Comment 7

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/70cc89f753ae
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
You need to log in before you can comment on or make changes to this bug.