bad parse of mailto url containing "% escaped" (?) characters

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
11 years ago

People

(Reporter: cwr, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020205
BuildID:    20020205

This page (http://newsseer.com/) contains a mailto link labeled
"Feedback" which is created by JavaScript.  When hovering over the
link, the URL is displayed (on the bottom line of the browser window)
as "mailto:feedback@newsseer.com?subject=NewsSeer feedback" but if I
mouse right and Copy Link Address it contains "% escaped" characters
(what are those called?) like this:

mailto:%66%65ed%62a%63%6b%40newss%65%65%72%2e%63o%6d?subject=NewsSeer%20feedback

Apparently this causes the parsing of the mailto to go awry.

Reproducible: Always
Steps to Reproduce:
1. go to http://newsseer.com/
2. click on "Feedback"


Actual Results:  The mail composition window that comes up looks like this:

    To: feedback@newsseer.com?subject=NewsSeer
    To: feedba
    Subject: NewsSeer feedback


Expected Results:  instead of:

    To: feedback@newsseer.com
    Subject: NewsSeer feedback


I hope this is not a duplicate, it seems like it might be related to:

Bugzilla Bug 125080
mailto url with raw non-ASCII subject and mail body is not working
http://bugzilla.mozilla.org/show_bug.cgi?id=125080

Comment 1

17 years ago
neat
Assignee: asa → blaker
Component: Browser-General → XP Apps: GUI Features
QA Contact: doronr → sairuh
This is not an XP apps thing... over to mailnews:networking where they do the
URI parsing.
Assignee: blaker → mscott
Status: UNCONFIRMED → NEW
Component: XP Apps: GUI Features → Networking - General
Ever confirmed: true
OS: Linux → All
Product: Browser → MailNews
QA Contact: sairuh → huang
Hardware: PC → All

Comment 4

17 years ago
This seems to work OK for me in 1.1 alpha.  Has it been fixed?

Comment 5

17 years ago
Also WFM in 2002-08-30-05 Linux

marking as such
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

17 years ago
At the risk of being redundant, it also works for me (the original whiner)
in release 1.1.  I gather it just "went away" as result of changes
elsewhere?  In any case, thanks for your help.

(Oddly, today when I went to http://newsseer.com/ to test this with my new
Mozilla 1.1, I found a completely unrelated problem with that page which
I just reported: http://bugzilla.mozilla.org/show_bug.cgi?id=168062)

Updated

16 years ago
QA Contact: huang → gchan
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.