Do not underline sources in the webconsole before hovering

RESOLVED WORKSFORME

Status

DevTools
Console
P3
normal
RESOLVED WORKSFORME
2 years ago
7 days ago

People

(Reporter: jsantell, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [btpp-fix-now])

Attachments

(1 attachment)

Created attachment 8729668 [details]
Screen Shot 2016-03-11 at 11.41.08 AM.png

Some console sources, like ones from warnings or errors, already display an underline, which doesn't look good, and looks weird when hovering over it. We should have these styled no different than normal console logging messages.

Probably have to change the location node in webconsole to something other than an anchor. Would get rid of this React warning as well:
"Warning: validateDOMNesting(...): <a> cannot appear as a descendant of <a>. See a > ... > Frame > a."
Marking as P1 since this is shipping with Bug 1251033
Blocks: 1251033
Priority: -- → P1
Whiteboard: [btpp-fix-now]
I haven't seen this underline style appear on nightly console. (I've reproduced same error messages on screen-shot but didn't see the underline source).

Is it still happened on your environment?
Flags: needinfo?(jsantell)
Not that I can see. Probably can be closed it, but maybe something working on webconsole will be more familiar.
Flags: needinfo?(jsantell)
I can't figure out how to reproduce the '(unknown)' source anymore.  Do you have any ideas for a STR to confirm this isn't an issue anymore?
Flags: needinfo?(rchien)
Priority: P1 → P3
I also cannot reproduce it anymore because I forgot what's the steps I last tried.
Flags: needinfo?(rchien)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

Updated

7 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.