[meta] Search / Filter Input Component

RESOLVED DUPLICATE of bug 1154789

Status

()

Firefox
Developer Tools: Shared Components
P2
normal
RESOLVED DUPLICATE of bug 1154789
2 years ago
a year ago

People

(Reporter: clarkbw, Unassigned)

Tracking

({meta})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [btpp-fix-later])

This meta bug is for tracking the work needed to have a robust and useful search input that can be shared throughout devtools.

Possible items off the top of my head are:
* placeholder text with visible keyboard shortcut e.g. "Search (⌘F)"
* clear button for clearing out search entry e.g. [ search text    | x ]
* previous / next buttons for navigating through search hits e.g. [ search t...][ \/ | /\ ]
* popup help menu as seen in the debugger "Search scripts" input
(Reporter)

Comment 1

2 years ago
See bug 1254111 for prev / next buttons request
(In reply to Bryan Clark (Firefox PM) [:clarkbw] from comment #0)
> This meta bug is for tracking the work needed to have a robust and useful
> search input that can be shared throughout devtools.

Makes sense to some kind of shared component for this.  Need to be aware that not all of our search boxes are for 'searching' - like webconsole, css rules view, netmonitor - and would probably be a different 'filter box' component.

> * popup help menu as seen in the debugger "Search scripts" input

I think we are trying to get away from the complexity that necessitates that popup, so hopefully we don't need to add it to a new component.
Here's a spreadsheet of most of the search/filters (see the Search/filter tab): https://docs.google.com/spreadsheets/d/1M6V_9aDdhAVdjeGYkv8gOKs513UK3AzDGjlbD_TKIiw/edit#gid=70037677
Priority: -- → P2
Whiteboard: [btpp-fix-later]

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1154789
You need to log in before you can comment on or make changes to this bug.