Other applications flashing with white in background if I resize firefox window or open context menu after mouse actions

VERIFIED WONTFIX

Status

()

VERIFIED WONTFIX
3 years ago
3 years ago

People

(Reporter: arni2033, Unassigned)

Tracking

(Depends on: 1 bug, {regression})

47 Branch
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox48 fix-optional)

Details

User Story

>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509

Correct STR:
1. Install and launch Fraps  (don't record any video, just launch)
2. Switch Firefox window in normal (not maximized) mode. Open new tab, make it empty (just in case)
3. Simply wait 10 seconds (yep)
4. Right-click on a free place

AR:  Background application using native elements flashes with white.
     Tested with Total Commander, Notepad++ and Windows Explorer (Win+E)
ER:  Background applications shouldn't blink   [?] (See comment 3)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
not-entirely-accuratesee-user-story
>>>   My Info:   Win7_64, Nightly 48, 32bit, ID 20160312030405
STR:
0. Switch firefox window in normal (not maximized) mode.
1. Open https://www.mozilla.org/en-US/firefox/nightly/firstrun/?oldversion=44.0.2
2. Move mouse pointer between "n" and "k" in string "Thank you", hold left mouse button
3. Move mouse pointer between "l" and "p" in string "nd help make", release left mouse button
4. Move mouse pointer between "a" and "k" in string "nd help make", hold left mouse button
5. Move mouse pointer between "o" and "u" in string "Thank you", release left mouse button
6. Repeat Steps 2-3. Repeat Steps 4-5
7. Hover mouse over identity block, hold left mouse button, move mouse over "Back" button
   in urlbar, release left mouse button
8. Click Australis Menu button (≡)
9.A) Right-click Australis Menu button (≡)
    (or, actually, any place that provides non-native context menu)
9.B) Minimize Firefox window, then click its button on task bar to restore it
9.C) Resize Firefox window using top left corner of application window

AR:  Background application using native elements flashes with white.
     Also reproducible with Notepad++ and Windows Explorer (Win+E)
ER:  Background applications shouldn't blink because of Firefox failures.

Note:
1) I can still reproduce it if I skip Step 7  [OR]  Step 8.
2) I recorded the video (A,C) using mobile phone, because for some reason there was no bug when
   almost all CPU was consumed by FRAPS. Anyway, the white flash is visible on that screencast

This is regression from bug 1232042. Regression range:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4e56796fa59b7be8d0ebc717f0a6db410cb3a0fa&tochange=2dd26535e73c160f9ce478cd0561b7722042c0d3
Comment hidden (spam)
(Reporter)

Updated

3 years ago
Summary: Other applications flashing with wite in background if I resize firefox window or open context menu after mouse actions → Other applications flashing with white in background if I resize firefox window or open context menu after mouse actions
(Reporter)

Updated

3 years ago
Depends on: 1256728
That looks like fun.
Flags: needinfo?(bas)
(Reporter)

Comment 3

3 years ago
Probably not. I figured out it was caused by Fraps, more info in UserStory.

Actually, it may easily end up wontfix, since it's caused by another application,
but this being a regression is still strange.
User Story: (updated)
(Reporter)

Updated

3 years ago
User Story: (updated)
(In reply to Milan Sreckovic [:milan] from comment #2)
> That looks like fun.

I can see how this might confuse Fraps somewhat and maybe cause other issues I suppose.
Flags: needinfo?(bas)

Updated

3 years ago
status-firefox48: affected → fix-optional
Component: Shell Integration → Graphics
Product: Firefox → Core
(In reply to arni2033 from comment #3)
> Probably not. I figured out it was caused by Fraps, more info in UserStory.
> 
> Actually, it may easily end up wontfix, since it's caused by another
> application, but this being a regression is still strange.

Doing the forced present was in the patch that caused this to show up, so I can see the correlation.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
Version: Trunk → 47 Branch
(Reporter)

Updated

3 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.