Encoded URL can't be passed to extension page

RESOLVED DUPLICATE of bug 719905

Status

RESOLVED DUPLICATE of bug 719905
3 years ago
3 months ago

People

(Reporter: frfxtst, Unassigned)

Tracking

(Blocks: 1 bug)

47 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: triaged)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160303134406

Steps to reproduce:

It seems not to be possible to pass an encoded url as an parameter to an extension page. I entered the following url:

moz-extension://a22cf3ea-6db2-4b8c-83d2-f4c344c4461b/testit.html?url=http%3A%2F%2Ftestit.com

The error message "The address isn't valid. The URL is not valid and cannot be loaded." is displayed.

This works without problems in Chrome.

Comment 1

3 years ago
I'm here with Kris who says this might be already (partially?) fixed, so I'm CCing him, thank you for filing it.
Flags: needinfo?(kmaglione+bmo)

Updated

3 years ago
Blocks: 1161828

Updated

2 years ago
Whiteboard: triaged

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(kmaglione+bmo)
Resolution: --- → DUPLICATE
Duplicate of bug: 719905

Updated

3 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.