Closed Bug 1256216 Opened 6 years ago Closed 5 years ago

[RTL] Don't overflow responsive design mode controls in RTL locales

Categories

(DevTools :: Responsive Design Mode, defect, P3)

defect

Tracking

(firefox47 affected, firefox48 affected, firefox49 affected, firefox50 affected)

RESOLVED INVALID
Tracking Status
firefox47 --- affected
firefox48 --- affected
firefox49 --- affected
firefox50 --- affected

People

(Reporter: magicp.jp, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [btpp-backlog])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160313030418

Steps to reproduce:

1. Start Nightly (RTL locales)
2. Open DevTools > Responsive Design Mode


Actual results:

Responsive design mode controls are overflowed. 


Expected results:

Don't overflow.
Has STR: --- → yes
Component: Untriaged → Developer Tools: Responsive Design Mode
OS: Unspecified → All
Hardware: Unspecified → All
Moving this to the backlog since we are actively redesigning RDM.  Hopefully we can cover RTL issues like this in the new layout.
Priority: -- → P3
Whiteboard: [btpp-backlog]
The new RDM UI shipping in Firefox 52 doesn't seem to have these issues.  It appears to use LTR all the time, from what I could see.
Blocks: dt-rtl
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.