Closed Bug 1256279 Opened 6 years ago Closed 6 years ago

(e10s-specific) Browser doesn't cancel downloading of a heavy page if I close tab (it consumes more and more RAM until browser crashes)

Categories

(Firefox :: Untriaged, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1256710
Tracking Status
e10s + ---
firefox48 --- affected

People

(Reporter: arni2033, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: crash, hang)

>>>   My Info:   Win7_64, Nightly 48, 32bit, ID 20160312030405
When I encounter unexpected heavy pages like in bug 1210236 (Firefox failure), I usually
try to close the tab as fast as possible. However, it doesn't help even in e10s mode.

STR:
0. Open http://example.org/ in a new tab (to load at least 1 normal page in content process)
1. Follow STR in bug 1210236 to open heavy web page [OR] emulate a heavy page:
 1.1. Choose any heavy video/exe file on your PC
 1.2. Copy that file. Rename it into .txt file. Drag it onto "New tab" button in Firefox
2. Open Task Manager, wait until content process consumes ~800Mb RAM
3. Close the tab opened in Step 1.
4. Wait 2 minutes

AR:
 Task Manager shows that despite the fact that I closed the tab, it is still loading
 and content process is consuming more and more RAM. And eventually it crashes.
 Note that for 64-bit versions it probably will be hang, not crash. It's still bad.
 For testing this on 64-bit versions I recommend to use ~2Gb videos renamed to txt files.

ER:  
 The browser should abort all actions related to the heavy page.
 That's the goal of multi-process - to prevent any crashes/hangs in described case.
Component: Untriaged → Download Manager
Product: Firefox → Toolkit
tracking-e10s: --- → +
Priority: -- → P2
How is this related to Download Manager if it's clearly about canceling loading of a huge page?
Not "downloading file" at all.
Component: Download Manager → Untriaged
Product: Toolkit → Firefox
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1256710
Depends on: 1256710
User Agent  Mozilla/5.0 (Windows NT 6.1; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID  20160328030215

Hi, 

I have tested this issue on Windows 7 x32 and x64 with FF Nightly 48.0a1 (2016-03-28) and I can't reproduce this issue, it works for me, I didn't reach more than 500mb in Task Manager and I was able to close the loading page after I clicked close button 2 times. About the crash report, I didn't had any crashes and I take a look into the crash report that you send it and I saw that are only 2 crashes in the last 28 days that have the same signature and that is a very low number.  I marked this a duplicate of bug 1256710 because it seems to me that are the same, you always have the option to reopen this issue if you consider that.
I also tested this on nightly
Mozilla/5.0 (Windows NT 6.1; rv:48.0) Gecko/20100101 Firefox/48.0
Version 	48.0a1
Build ID 	20160324154036
Windows 7 / 32 bits.
A few tabs already open in my browser, I followed STR, downloaded the complete file. Never went above 280 MB of RAM used by Firefox (no peak).
See Also: → 1164189
You need to log in before you can comment on or make changes to this bug.