Minimize, maximize and close buttons shrink considerable when switching from low dpi monitor to retina display

RESOLVED DUPLICATE of bug 1247272

Status

()

Firefox
Toolbars and Customization
RESOLVED DUPLICATE of bug 1247272
2 years ago
2 years ago

People

(Reporter: bogdan_maris, Unassigned)

Tracking

({regression})

47 Branch
All
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox45 unaffected, firefox46 unaffected, firefox47 fixed, firefox48 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8730208 [details]
Screenshot showing the issue

[Note]:
-

[Affected versions]:
- Developer Edition 47.0a2
- Latest Nightly 48.0a1

[Affected platforms]:
- Mac OS X 10.11.1 (Macbook with Retina display + another monitor 'fullHD or lower')

[Steps to reproduce]:
1. Start Firefox on the second monitor
2. Move Firefox to Retina display

[Expected result]:
- No layout, theme issues can be seen, the scaling of items is properly done.

[Actual result]:
- Minimize, maximize and close icons are visible shrinked.

[Regression range]:
- I was unable to make mozregression work from some unknown reason (will try to make it work asap). I did a manual regression on mozilla-central tinderbox builds:

Last good build: 2016-02-09
First bad build: 2016-02-10

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d1a54ae63da7ebc4bc1eeb5b613e8ec29bfcb80a&tochange=2dfb45d74f42d2a0010696f5fd47c7a7da94cedb

Please set the regressionwindow-wanted in keywords if a more indepth regression is needed.

[Additional notes]:
- Screenshot with the issue attached.
(Reporter)

Comment 1

2 years ago
Jonathan, do you think this has something to do with per-monitor DPI feature? I know it's not supported on Mac but maybe something broke related to the feature might have broke this.
Flags: needinfo?(jfkthame)
This sounds like bug 1247272 to me, which is a regression from bug 1243418.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(jfkthame)
Resolution: --- → DUPLICATE
Duplicate of bug: 1243418
Duplicate of bug: 1247272
status-firefox47: affected → fixed
status-firefox48: affected → fixed
You need to log in before you can comment on or make changes to this bug.