WebGL is non functional

RESOLVED FIXED in Firefox 45

Status

()

Firefox for Android
Toolbar
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: kbrosnan, Assigned: dvander)

Tracking

Trunk
Firefox 48
Points:
---

Firefox Tracking Flags

(firefox45+ verified, firefox46 fixed, firefox47 fixed, firefox48 unaffected, relnote-firefox 45+, fennec45+)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
[Tracking Requested - why for this release]: major web feature broken

I have tested several webgl sites and they all report that webgl is non functional.

http://get.webgl.org/
http://doesmybrowsersupportwebgl.com/

From https://support.mozilla.org/en-US/questions/1114216
Works here on Nexus 6P. What hardware are you on?
Works on Nexus 9 and Nexus 4 as well. Not sure what's going on, but logcat from an affected device may help.
Flags: needinfo?(kbrosnan)
Kevin says he says 'GLContext is disabled' type of messages in the logcat, presumably due to the crashes. Milan, I think it makes sense to just disable that stuff on Android, sense no configuration changes (driver upgrades) are really possible.
Flags: needinfo?(kbrosnan) → needinfo?(milan)
(Reporter)

Comment 4

2 years ago
Created attachment 8730347 [details]
1256371.txt

Full logcat
Milan is PTO this week, redirecting to dvander who I believe is working on this stuff.
Flags: needinfo?(dvander)
Created attachment 8730363 [details] [diff] [review]
patch

Sounds reasonable.
Assignee: nobody → dvander
Status: NEW → ASSIGNED
Flags: needinfo?(milan)
Flags: needinfo?(dvander)
Attachment #8730363 - Flags: review?(snorp)
Comment on attachment 8730363 [details] [diff] [review]
patch

Review of attachment 8730363 [details] [diff] [review]:
-----------------------------------------------------------------

Will this also enable WebGL for people where it has been disabled by the crash guard?
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #7)
> Comment on attachment 8730363 [details] [diff] [review]
> patch
> 
> Review of attachment 8730363 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Will this also enable WebGL for people where it has been disabled by the
> crash guard?

Yup.
Comment on attachment 8730363 [details] [diff] [review]
patch

Review of attachment 8730363 [details] [diff] [review]:
-----------------------------------------------------------------

We'll want to uplift this basically everywhere, including release if there is a dot release
Attachment #8730363 - Flags: review?(snorp) → review+
James, David, I am going to start the build of dot release very soon, could you fill the uplift request? Thanks
Flags: needinfo?(snorp)
Flags: needinfo?(dvander)
Comment on attachment 8730363 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: bug 1190281
[User impact if declined]: No WebGL support for users where WebGL crashed.
[Describe test coverage new/current, TreeHerder]:
[Risks and why]: No risk, aside from unblocking WebGL for users where it once crashed, so there's a chance they may crash again. This isn't anywhere near as severe as a startup crash which is what the guard was intended to prevent.
[String/UUID change made/needed]:
Flags: needinfo?(dvander)
Attachment #8730363 - Flags: approval-mozilla-release?
Attachment #8730363 - Flags: approval-mozilla-beta?
Attachment #8730363 - Flags: approval-mozilla-aurora?
Comment on attachment 8730363 [details] [diff] [review]
patch

Needed for 45.0.1 fennec

Ryan, very sorry but could you land that? Thanks
Flags: needinfo?(ryanvm)
Attachment #8730363 - Flags: approval-mozilla-release?
Attachment #8730363 - Flags: approval-mozilla-release+
Attachment #8730363 - Flags: approval-mozilla-beta?
Attachment #8730363 - Flags: approval-mozilla-beta+
Attachment #8730363 - Flags: approval-mozilla-aurora?
Attachment #8730363 - Flags: approval-mozilla-aurora+
I can get it.
Flags: needinfo?(ryanvm)
Here's release, I'll get the other trees when I look through the rest of the uplift requests:

https://hg.mozilla.org/releases/mozilla-release/rev/910c9ac881ee
status-firefox45: affected → fixed
status-firefox46: --- → affected
status-firefox47: --- → affected

Comment 17

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7773387a9a2f
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
Added to the release notes with "Bring back WebGL support on some devices (1256371)" as wording
tracking-firefox45: ? → +
relnote-firefox: --- → 45+
(In reply to Carsten Book [:Tomcat] from comment #18)
> https://hg.mozilla.org/mozilla-central/rev/5a1e75dd9d54

dvander so this is the final patch that needs to land on beta and co ?
Flags: needinfo?(dvander)

Comment 21

2 years ago
I was able to reproduce this issue on Firefox 45.0 with the following STR: 
1. Install crashme add-on
2. Open http://get.webgl.org/ the very quickly crash Firefox
1/2 times I was able to reproduce the issue

Verified as fixed on Firefox 45.0.1 following the STR from above, and wasn't able to reproduce at all.
status-firefox45: fixed → verified
(In reply to Carsten Book [:Tomcat] from comment #20)
> (In reply to Carsten Book [:Tomcat] from comment #18)
> > https://hg.mozilla.org/mozilla-central/rev/5a1e75dd9d54
> 
> dvander so this is the final patch that needs to land on beta and co ?

Yup.
Flags: needinfo?(dvander)
tracking-fennec: ? → 45+
Flags: needinfo?(snorp)

Comment 23

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/85a96d03d818
status-firefox47: affected → fixed

Comment 24

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/6b7212e05883
status-firefox46: affected → fixed
You need to log in before you can comment on or make changes to this bug.