Last Comment Bug 1256521 - SAPI speech rate conversion is not accurate
: SAPI speech rate conversion is not accurate
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Web Speech (show other bugs)
: unspecified
: Unspecified Windows
-- normal (vote)
: mozilla48
Assigned To: Eitan Isaacson [:eeejay]
:
: André Natal
Mentors:
http://eeejay.github.io/webspeechdemo...
Depends on:
Blocks: 1254234
  Show dependency treegraph
 
Reported: 2016-03-14 19:19 PDT by Eitan Isaacson [:eeejay]
Modified: 2016-03-17 03:19 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Normalize speech rate in Windows. (1.66 KB, patch)
2016-03-14 19:21 PDT, Eitan Isaacson [:eeejay]
no flags Details | Diff | Splinter Review
Normalize speech rate in Windows. (1.69 KB, patch)
2016-03-15 11:13 PDT, Eitan Isaacson [:eeejay]
bugs: review-
Details | Diff | Splinter Review
Normalize speech rate in Windows. r?smaug (1.74 KB, patch)
2016-03-16 11:02 PDT, Eitan Isaacson [:eeejay]
bugs: review+
Details | Diff | Splinter Review

Description User image Eitan Isaacson [:eeejay] 2016-03-14 19:19:06 PDT
The speech rate that is given is not correctly reflected in the output. For example, setting the uttance rate to 2, gives an increase of 1.43x.
Comment 1 User image Eitan Isaacson [:eeejay] 2016-03-14 19:21:44 PDT
Created attachment 8730490 [details] [diff] [review]
Normalize speech rate in Windows.

MozReview-Commit-ID: EuQAqfoxwmo
Comment 3 User image Eitan Isaacson [:eeejay] 2016-03-15 11:13:11 PDT
Created attachment 8730840 [details] [diff] [review]
Normalize speech rate in Windows.

I removed the min/max clipping to allow the underlying engine to deal with rate values outside
the official "supported" range.
Comment 4 User image Olli Pettay [:smaug] (pto-ish for couple of days) 2016-03-15 15:11:04 PDT
Comment on attachment 8730840 [details] [diff] [review]
Normalize speech rate in Windows.

Am I missing something here, or does passing rate 0 really not work?
And since aRate isn't bounded in anyway, how is end results supposed to be [-10,10]
Comment 5 User image Olli Pettay [:smaug] (pto-ish for couple of days) 2016-03-15 15:11:45 PDT
With 0 case I mean that it is unclear what actually happens if 0 is passed as rate.
Comment 6 User image Eitan Isaacson [:eeejay] 2016-03-16 10:09:28 PDT
(In reply to Olli Pettay [:smaug] from comment #4)
> Comment on attachment 8730840 [details] [diff] [review]
> Normalize speech rate in Windows.
> 
> Am I missing something here, or does passing rate 0 really not work?

Oops, totally bad stuff happens.

> And since aRate isn't bounded in anyway, how is end results supposed to be
> [-10,10]

According to the msdn docs, values above those bounds are allowed, but the engine does not need to support anything beyond.

But there is a good point here, SpeechSynthesisUtterance.rate should bind the rate to 0.1-10. From a test with Chrome, they do that. I'll open a new bug for that.
Comment 7 User image Eitan Isaacson [:eeejay] 2016-03-16 11:02:19 PDT
Created attachment 8731350 [details] [diff] [review]
Normalize speech rate in Windows. r?smaug

MozReview-Commit-ID: EuQAqfoxwmo
Comment 9 User image Carsten Book [:Tomcat] 2016-03-17 03:19:02 PDT
https://hg.mozilla.org/mozilla-central/rev/5cb9d1e18724

Note You need to log in before you can comment on or make changes to this bug.