[e10s] "color" property is not honored on <option> elements in select dropdown

RESOLVED DUPLICATE of bug 910022

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 910022
2 years ago
2 years ago

People

(Reporter: Jon Clapp, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160315004019

Steps to reproduce:

I visited a page with HTML SELECT OPTION elements styled with css Color = Silver with Firefox Developer Edition (v 47.0a2).


Actual results:

All HTML SELECT OPTION elements were rendered with the default color of black for the font color.


Expected results:

In the release version of Firefox the HTML SELECT OPTION elements styled with css Color = Silver appear silver.

Updated

2 years ago
Component: Untriaged → Layout: Form Controls
Product: Firefox → Core
Could you provide a testcase or a URL that demonstrates the issue?
Flags: needinfo?(j_w_clapp)
(Reporter)

Comment 2

2 years ago
Created attachment 8730916 [details]
FindRequest.html - simple html page with two silver Options at the bottom of a Select

In this html file (FindRequest.html), the bottom 2 options in the select appear black in the current Firefox Dev Edition, but appear silver (as they should) in the current Firefox release version.
Flags: needinfo?(j_w_clapp)
Thanks. This seems to be an e10s-dependent bug -- I get expected results (silver text for the last 2 options) in DevEdition & Nightly, *if* I disable e10s (multi-process support), via the checkbox at the top of Firefox Preferences.

So, this seems to be a behavior-change caused by our switch to e10s.
Status: UNCONFIRMED → NEW
tracking-e10s: --- → ?
Ever confirmed: true
Summary: css color option → [e10s] "color" property is not honored on <option> elements in select dropdown
Version: 47 Branch → Trunk
Actually, I think this is covered by existing bug 910022. (See bug 910022 comment 0 there -- it talks about a bunch of different styles not working on <option>, with e10s enabled, including 'color'.)

Marking as a duplicate, so that we don't accidentally track/discuss one issue in two separate places.

Thanks for the bug report, in any case!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
tracking-e10s: ? → ---
Resolution: --- → DUPLICATE
Duplicate of bug: 910022
You need to log in before you can comment on or make changes to this bug.