Last Comment Bug 1256795 - [ESLint] Fix ESLint issues in devtools/client/webconsole/test/browser_console_server_logging.js
: [ESLint] Fix ESLint issues in devtools/client/webconsole/test/browser_console...
Status: RESOLVED FIXED
[btpp-backlog]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: unspecified
: Unspecified Unspecified
P3 normal (vote)
: Firefox 49
Assigned To: a.l.e
:
: (Unavailable until Apr 3) [:bgrins]
Mentors: Jason Laster [:jlast]
Lin Clark [:linclark]
Depends on:
Blocks: 1256948
  Show dependency treegraph
 
Reported: 2016-03-15 12:09 PDT by Lin Clark [:linclark]
Modified: 2016-05-30 06:40 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
0001-Bug-1256795-ESLint-Fix-ESLint-issues-in-devtools-cli.patch (1.81 KB, patch)
2016-04-30 07:39 PDT, a.l.e
lclark: review+
Details | Diff | Splinter Review
updated_commitmessage_reviewer_added (1.81 KB, patch)
2016-05-05 12:17 PDT, Michael Kohler [:mkohler]
me: review+
Details | Diff | Splinter Review

Description User image Lin Clark [:linclark] 2016-03-15 12:09:54 PDT
If you haven’t contributed to Firefox before, follow the steps here to set up your environment: https://developer.mozilla.org/en-US/docs/Tools/Contributing#Getting_set_up

Then, automatically configure ESLint to work with the Firefox specific rules by following the instructions here: https://wiki.mozilla.org/DevTools/CodingStandards

Then you can see the issues that need to be fixed by running

> eslint --no-ignore devtools/client/webconsole/test/browser_console_server_logging.js
Comment 1 User image a.l.e 2016-04-30 07:39:22 PDT
Created attachment 8747443 [details] [diff] [review]
0001-Bug-1256795-ESLint-Fix-ESLint-issues-in-devtools-cli.patch

more greetings from the firefox hackaton in zurich
Comment 2 User image Michael Kohler [:mkohler] 2016-04-30 07:44:37 PDT
https://treeherder.mozilla.org/#/jobs?repo=try&revision=455181a695f1
Comment 3 User image Lin Clark [:linclark] 2016-05-02 08:16:09 PDT
Comment on attachment 8747443 [details] [diff] [review]
0001-Bug-1256795-ESLint-Fix-ESLint-issues-in-devtools-cli.patch

Review of attachment 8747443 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me!

Could you fix up the commit message for this one before we commit?
Comment 4 User image Michael Kohler [:mkohler] 2016-05-05 12:17:57 PDT
Created attachment 8749350 [details] [diff] [review]
updated_commitmessage_reviewer_added
Comment 5 User image Michael Kohler [:mkohler] 2016-05-05 12:18:44 PDT
I felt free to update the commit message for you since this includes a fix that will be useful for a whole lot of other ESLint bugs :)

Thanks for the patch!
Comment 7 User image Carsten Book [:Tomcat] 2016-05-06 03:12:11 PDT
https://hg.mozilla.org/mozilla-central/rev/779aadcbc188
Comment 8 User image Ryan VanderMeulen [:RyanVM] 2016-05-30 06:40:59 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/c443cfd5fb7c

Note You need to log in before you can comment on or make changes to this bug.