Last Comment Bug 1256863 - [ESLint] Fix ESLint issues in devtools/client/webconsole/test/browser_webconsole_bug_646025_console_file_location.js
: [ESLint] Fix ESLint issues in devtools/client/webconsole/test/browser_webcons...
Status: RESOLVED FIXED
[btpp-backlog]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: unspecified
: Unspecified Unspecified
P3 normal (vote)
: Firefox 49
Assigned To: Michael Kohler [:mkohler]
:
: (Unavailable until Apr 3) [:bgrins]
Mentors: Jason Laster [:jlast]
Lin Clark [:linclark]
: 1265231 (view as bug list)
Depends on:
Blocks: 1256948
  Show dependency treegraph
 
Reported: 2016-03-15 12:23 PDT by Lin Clark [:linclark]
Modified: 2016-05-30 06:41 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
0001-Bug-1256863-ESLint-Fix-ESLint-issues-in-devtools-cli.patch (1.32 KB, patch)
2016-04-30 09:00 PDT, Michael Kohler [:mkohler]
no flags Details | Diff | Splinter Review
0001-Bug-1256863-ESLint-Fix-ESLint-issues-in-devtools-cli.patch (849 bytes, patch)
2016-05-02 12:28 PDT, Michael Kohler [:mkohler]
lclark: review+
Details | Diff | Splinter Review

Description User image Lin Clark [:linclark] 2016-03-15 12:23:49 PDT
If you haven’t contributed to Firefox before, follow the steps here to set up your environment: https://developer.mozilla.org/en-US/docs/Tools/Contributing#Getting_set_up

Then, automatically configure ESLint to work with the Firefox specific rules by following the instructions here: https://wiki.mozilla.org/DevTools/CodingStandards

Then you can see the issues that need to be fixed by running

> eslint --no-ignore devtools/client/webconsole/test/browser_webconsole_bug_646025_console_file_location.js
Comment 1 User image Michael Kohler [:mkohler] 2016-04-30 09:00:10 PDT
Created attachment 8747456 [details] [diff] [review]
0001-Bug-1256863-ESLint-Fix-ESLint-issues-in-devtools-cli.patch
Comment 2 User image Michael Kohler [:mkohler] 2016-04-30 15:04:09 PDT
https://treeherder.mozilla.org/#/jobs?repo=try&revision=19bfa6c25e28
Comment 3 User image Lin Clark [:linclark] 2016-05-02 08:25:33 PDT
Comment on attachment 8747456 [details] [diff] [review]
0001-Bug-1256863-ESLint-Fix-ESLint-issues-in-devtools-cli.patch

Review of attachment 8747456 [details] [diff] [review]:
-----------------------------------------------------------------

I'm glad we're getting rid of so many CPOWs. This will probably clear up a bunch of intermittents along the way.

There's actually another way to do this that someone told me in a review of my code. Here's an example:

https://dxr.mozilla.org/mozilla-central/source/devtools/client/webconsole/test/browser_webconsole_bug_658368_time_methods.js#62
Comment 4 User image Michael Kohler [:mkohler] 2016-05-02 12:27:28 PDT
https://treeherder.mozilla.org/#/jobs?repo=try&revision=2fbbe126415a
Comment 5 User image Michael Kohler [:mkohler] 2016-05-02 12:28:25 PDT
Created attachment 8747889 [details] [diff] [review]
0001-Bug-1256863-ESLint-Fix-ESLint-issues-in-devtools-cli.patch

https://treeherder.mozilla.org/#/jobs?repo=try&revision=07cdc4be7841
Comment 6 User image Lin Clark [:linclark] 2016-05-02 13:23:06 PDT
Comment on attachment 8747889 [details] [diff] [review]
0001-Bug-1256863-ESLint-Fix-ESLint-issues-in-devtools-cli.patch

Review of attachment 8747889 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good! Feel free to add checkin-needed once it passes on try.
Comment 8 User image Carsten Book [:Tomcat] 2016-05-04 02:50:47 PDT
https://hg.mozilla.org/mozilla-central/rev/8e8b4d74e547
Comment 9 User image (Unavailable until Apr 3) [:bgrins] 2016-05-05 11:31:56 PDT
*** Bug 1265231 has been marked as a duplicate of this bug. ***
Comment 10 User image Ryan VanderMeulen [:RyanVM] 2016-05-30 06:41:22 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/5108e581ac5c

Note You need to log in before you can comment on or make changes to this bug.