Last Comment Bug 1256895 - [ESLint] Fix ESLint issues in devtools/client/webconsole/test/browser_webconsole_live_filtering_of_message_types.js
: [ESLint] Fix ESLint issues in devtools/client/webconsole/test/browser_webcons...
Status: RESOLVED DUPLICATE of bug 1177324
[btpp-backlog]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: unspecified
: Unspecified Unspecified
P3 normal (vote)
: ---
Assigned To: a.l.e
:
: (Unavailable until Apr 3) [:bgrins]
Mentors: Jason Laster [:jlast]
Lin Clark [:linclark]
Depends on:
Blocks: 1256948
  Show dependency treegraph
 
Reported: 2016-03-15 12:30 PDT by Lin Clark [:linclark]
Modified: 2016-06-09 06:08 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
0001-Bug-1256895-ESLint-Fix-ESLint-issues-in-devtools-cli.patch (1.22 KB, patch)
2016-04-30 06:57 PDT, a.l.e
lclark: review+
Details | Diff | Splinter Review

Description User image Lin Clark [:linclark] 2016-03-15 12:30:31 PDT
If you haven’t contributed to Firefox before, follow the steps here to set up your environment: https://developer.mozilla.org/en-US/docs/Tools/Contributing#Getting_set_up

Then, automatically configure ESLint to work with the Firefox specific rules by following the instructions here: https://wiki.mozilla.org/DevTools/CodingStandards

Then you can see the issues that need to be fixed by running

> eslint --no-ignore devtools/client/webconsole/test/browser_webconsole_live_filtering_of_message_types.js
Comment 1 User image a.l.e 2016-04-30 06:57:02 PDT
Created attachment 8747435 [details] [diff] [review]
0001-Bug-1256895-ESLint-Fix-ESLint-issues-in-devtools-cli.patch

greetings from the zurich mozilla hackaton!
Comment 2 User image Michael Kohler [:mkohler] 2016-04-30 07:15:59 PDT
https://treeherder.mozilla.org/#/jobs?repo=try&revision=a0263376aaf2
Comment 3 User image Lin Clark [:linclark] 2016-05-02 07:29:11 PDT
Comment on attachment 8747435 [details] [diff] [review]
0001-Bug-1256895-ESLint-Fix-ESLint-issues-in-devtools-cli.patch

Review of attachment 8747435 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good, thanks!
Comment 4 User image Lin Clark [:linclark] 2016-05-02 07:37:21 PDT
Before we commit this, could you update the patch's commit message?

Change this line:

> Bug 1256895 - [ESLint] Fix ESLint issues in devtools/client/webconsole/test/browser_webconsole_live_filtering_of_message_types.js

To: 

> Bug 1256895 - [ESLint] Fix ESLint issues in devtools/client/webconsole/test/browser_webconsole_live_filtering_of_message_types.js. r=linclark


And for the user, unfortunately I don't think that we support having multiple users, so please delete the " + richard eigenmann" part.
Comment 5 User image Michael Kohler [:mkohler] 2016-05-02 09:47:10 PDT
Changing the commit message can be done locally, you don't need to use Janitor for that. Do you guys want me to do that or do you want to finish this?


(In reply to Lin Clark [:linclark] from comment #4)
> And for the user, unfortunately I don't think that we support having
> multiple users, so please delete the " + richard eigenmann" part.

As discussed with Lin through IRC, this won't be necessary since we don't have strict ties to other systems there. We definitely want to credit both of you :)

Small note: in case the "New contributors to Firefox" list that comes out with every Firefox release looks for those names, it will display exactly that. If it doesn't and looks at the Bugzilla name, then maybe just Ale will be credited in the post.
Comment 6 User image Jan Keromnes [:janx] 2016-06-09 06:08:46 PDT
Thanks a lot Ale and Richard for this patch!

Unfortunately we weren't able to land it in time, and bug 1177324 fixed the same problem again (bug 1271084 auto-fixed the space to the generator function).

If you liked contributing to Firefox, and would like to try fixing other Firefox / Devtools bugs, there are great resources to find good first bugs, such as:

http://www.joshmatthews.net/bugsahoy/

and

http://firefox-dev.tools/

*** This bug has been marked as a duplicate of bug 1177324 ***

Note You need to log in before you can comment on or make changes to this bug.