Last Comment Bug 1256936 - [ESLint] Fix ESLint issues in devtools/client/webconsole/test/test-bug-603750-websocket.js
: [ESLint] Fix ESLint issues in devtools/client/webconsole/test/test-bug-603750...
Status: RESOLVED FIXED
[btpp-backlog]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: unspecified
: Unspecified Unspecified
P3 normal (vote)
: Firefox 50
Assigned To: Fabien
:
: (Unavailable until Apr 3) [:bgrins]
Mentors: Jason Laster [:jlast]
Lin Clark [:linclark]
Depends on:
Blocks: 1256948
  Show dependency treegraph
 
Reported: 2016-03-15 12:38 PDT by Lin Clark [:linclark]
Modified: 2016-06-23 12:51 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
fixed


Attachments
0001-Last-Comment-Bug-1256936-ESLint-Fix-ESLint-issues-in.patch (1.09 KB, patch)
2016-04-30 07:05 PDT, Fabien
no flags Details | Diff | Splinter Review
0001-Last-Comment-Bug-1256936-ESLint-Fix-ESLint-issues-in.patch (1.08 KB, patch)
2016-04-30 07:24 PDT, Fabien
lclark: review+
Details | Diff | Splinter Review
0001-Last-Comment-Bug-1256936-ESLint-Fix-ESLint-issues-in.patch (1.09 KB, patch)
2016-06-08 08:53 PDT, Jan Keromnes [:janx]
janx: review+
Details | Diff | Splinter Review
0001-Last-Comment-Bug-1256936-ESLint-Fix-ESLint-issues-in.patch (1.03 KB, patch)
2016-06-08 09:07 PDT, Jan Keromnes [:janx]
janx: review+
Details | Diff | Splinter Review

Description User image Lin Clark [:linclark] 2016-03-15 12:38:49 PDT
If you haven’t contributed to Firefox before, follow the steps here to set up your environment: https://developer.mozilla.org/en-US/docs/Tools/Contributing#Getting_set_up

Then, automatically configure ESLint to work with the Firefox specific rules by following the instructions here: https://wiki.mozilla.org/DevTools/CodingStandards

Then you can see the issues that need to be fixed by running

> eslint --no-ignore devtools/client/webconsole/test/test-bug-603750-websocket.js
Comment 1 User image Fabien 2016-04-30 07:05:12 PDT
Created attachment 8747437 [details] [diff] [review]
0001-Last-Comment-Bug-1256936-ESLint-Fix-ESLint-issues-in.patch
Comment 2 User image Michael Kohler [:mkohler] 2016-04-30 07:14:29 PDT
https://treeherder.mozilla.org/#/jobs?repo=try&revision=a0263376aaf2
Comment 3 User image Fabien 2016-04-30 07:24:43 PDT
Created attachment 8747440 [details] [diff] [review]
0001-Last-Comment-Bug-1256936-ESLint-Fix-ESLint-issues-in.patch

Previous patch contained a typo in the commit message
Comment 4 User image Lin Clark [:linclark] 2016-05-02 07:52:11 PDT
Comment on attachment 8747440 [details] [diff] [review]
0001-Last-Comment-Bug-1256936-ESLint-Fix-ESLint-issues-in.patch

Review of attachment 8747440 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me, thanks!
Comment 5 User image Lin Clark [:linclark] 2016-05-02 07:53:35 PDT
Before we commit this, could you update the patch to include the reviewer?

You can just change this:

> Bug 1256936 - [ESLint] Fix ESLint issues in devtools/client/webconsole/test/test-bug-603750-websocket.js

To this:

> Bug 1256936 - [ESLint] Fix ESLint issues in devtools/client/webconsole/test/test-bug-603750-websocket.js. r=linclark
Comment 6 User image Jan Keromnes [:janx] 2016-06-08 08:53:39 PDT
Created attachment 8761270 [details] [diff] [review]
0001-Last-Comment-Bug-1256936-ESLint-Fix-ESLint-issues-in.patch

(I just added ". r=linclark" to the attachment description as requested in comment 5. No change otherwise, carrying over r+ from comment 4.)
Comment 7 User image Jan Keromnes [:janx] 2016-06-08 08:54:29 PDT
Comment on attachment 8761270 [details] [diff] [review]
0001-Last-Comment-Bug-1256936-ESLint-Fix-ESLint-issues-in.patch

(Actually carrying over r+ this time.)
Comment 8 User image Jan Keromnes [:janx] 2016-06-08 09:07:21 PDT
Created attachment 8761278 [details] [diff] [review]
0001-Last-Comment-Bug-1256936-ESLint-Fix-ESLint-issues-in.patch

(Trivial rebase on top of https://hg.mozilla.org/mozilla-central/rev/c4b1eb619c41 )
Comment 9 User image Jan Keromnes [:janx] 2016-06-08 09:50:03 PDT
No try because it's a simple non-functional change in syntax (but I verified it works locally just in case).
Comment 10 User image Pulsebot 2016-06-08 21:48:32 PDT
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/40635a4d3e9b
[ESLint] Fix ESLint issues in devtools/client/webconsole/test/test-bug-603750-websocket.js. r=linclark
Comment 11 User image Carsten Book [:Tomcat] 2016-06-09 03:12:42 PDT
https://hg.mozilla.org/mozilla-central/rev/40635a4d3e9b
Comment 12 User image Ryan VanderMeulen [:RyanVM] 2016-06-23 08:58:41 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/3217b202aab6
Comment 13 User image Ryan VanderMeulen [:RyanVM] 2016-06-23 12:51:45 PDT
https://hg.mozilla.org/releases/mozilla-beta/rev/3fc47c0f759c

Note You need to log in before you can comment on or make changes to this bug.